Latest FX Version Shows Annoying Action Center Notifications When Switching Playback Devices. And When I Completely Disable All Notifications For FxSound, they re-enable themselves! I've tried everything. Any Ideas? THANKS!

Oh, forgot…not sure how to get them disabled and make them stick thru a reboot. Too busy today to search it, but may have to dive in registry.

Say, anyway I can DL the version Before this one instead, until it’s fixed?

thanks!

1 Like

Sure, if one of those didn’t have this bug, and you’re willing to trade in the updates outlined in the Changelog for that.
You can find free downloads of all the previous versions [EDIT] on VideoHelp here:

Same problem here on windows 10 also, Downloaded version 1.1.16.0 to fix problem. So far so good.

1 Like

I considered downgrading as well, but reconsidered as the dev mentioned in this thread that new old v has memory leak bug. so vs mem leaks or annoying notifications, I personally, am going to stick with the latest version - lesser of 2 evils thing.

BTW, one quick way to clear the # of new notifications from showing in the action center [this goes for ANY notifications] is to press WinKey + A +A, it quickly opens-then closes & clears the # count in action center -, but the notifications are still left when you open up action center, and you can clear them later.

1 Like

Good point but notifications are like my pet peeve, lol, hate them. But thanks.

1 Like

Oh, me too…I’ve gone into either super admin or God Mode to stop some of them… and bricked my puter so f-ing bad, my only solution was to fresh install windows -…LOL…but in the big picture this software is FREE as free can get and IMO the best and easiest to use out there, so, I’m not gonna complain too loudly! LOL!

I just started using it a couple weeks ago to test and this free soft is one of the very few good ones that I’d even consider making a donation for. Kudos to the devs!

1 Like

I grabbed this info from windows event viewer. not sure if it’ll help you or not. thanks

Description
Faulting application name: FxSound.exe, version: 1.1.18.0, time stamp: 0x649b145e
Faulting module name: FxSound.exe, version: 1.1.18.0, time stamp: 0x649b145e
Exception code: 0xc0000005
Fault offset: 0x00000000000bd070
Faulting process id: 0x1284
Faulting application start time: 0x01d9b2dfa4e17397
Faulting application path: C:\Program Files\FxSound LLC\FxSound\FxSound.exe
Faulting module path: C:\Program Files\FxSound LLC\FxSound\FxSound.exe
Report Id: f94c47fa-2794-4297-8be5-38de7d375fbc
Faulting package full name:
Faulting package-relative application ID:

1 Like

I’m actually not a dev, only a mod, and also kind of a noob when it comes down to technical matters. :nerd_face:
But thanks for sharing nonetheless, maybe it will help Vijay (FxSound’s lead engineer).

I think it’s useful for this problem to indicate the level of user rights where the problem with system notifications occurs (user, admin, guest, etc). In the OS settings, the basic levels (groups), in the professional mode, there are more options.

It also cannot be ruled out that the problem is in the system itself, with its notification center. Therefore, make sure that the latest system updates are installed.
I can suggest that the developer should give the user a logging program (debug version or run command/key) that will keep track of the correct actions of the program and transfer them to the system. Previously, the program had its own functionality, but now it relies on Microsoft. In case of system errors, the FXSound developer does not have the ability to change the system itself.

Maybe you should also supplement the theme with screenshots of notifications, notification settings in the system.

All this is optional at the moment. But more information will give a more accurate analysis of the situation and a chance to repeat it, and then the opportunity to correct it.

1 Like

In Windows 10 I see that disabling FxSound notifications in the system settings doesn’t show the notifications until applications exits.


But OS is persisting the settings and when the application starts again, notifications start to appear unless they are disabled again.
Since the OS behaviour is different from Windows 11, I need to debug this further and implement an OS specific fix.

3 Likes

Thank you SO much for your work. Please, take your sweet time - there is NO rush, IMO as the bug is just they’re some just slightly annoying action center notifications, which, in the big picture does NOTHING to detract from your absolutely wonderful App.

And if I may dare at this time…lol, ask for a minor improvement/mod whilst you’re under the hood of this thing; Any way you can make the app’s, bubble/notification thing -when you switch sound outputs, go away all together or be at least an option with bubble display time editable? As after perusing the forums - other users have mentioned this very issue. It hovers RIGHT over the bottom right corner of the system tray, which impedes us impatient and OCD power users from clicking on anything in that area of the tray until it’s gone. If you’ve already updated this, then KUDOS! As it seemingly does NOT do it on MY system, but my win10OS is highly tweaked and modded toward security and data-mining.

Again, thank you SO much for this superb app, and when you get this little bug ironed out, expect a donation from me - a new user of just a couple of weeks - to help support this app, your efforts and expertise!

Kindest regards,

~NUTZ

1 Like

You’re not wrong…

Still experiencing this with v1.1.20.0 on windows 10.

The notifications are re-enabled upon reboot.

Any options I can run to allow a debug log, or debug build?

I am runnig the version from the website, rather than the MS store version

1 Like

Thanks for reporting this.

Vijay will be back in about two days, I will forward your question then.
Link to the issue on GitHub, if you’d like to keep track,

You obviously did not even make the effort to read the full issue I linked above.

Hi @arogl
Turning off notifications from system settings for the application is not persisting. We are working on providing an option in application settings to disable the notifications.

1 Like

@bvijay

Is it a bug in FXSound that is turning the option back on again? Thi ssi an OS level change that is reset by something?

I saw a previous change log entry that said made notifications stay off for win 11, I assume it needs a check for lower versions and use that logic.

1 Like

I looked it up; this was indeed mentioned upon release of v1.1.17.0:

Hi @arogl
For both Windows 10 and Windows 11, the application code queries OS settings if notifications can be displayed and then shows the notifications. Disabling the notifications and saving the settings is not done in the application. I haven’t found any documentation on the difference in OS APIs in Windows 10 and Windows 11 for handling notification. I will see if we can query any system registry setting to know if the application notifications or turned off. If this method doesn’t work, we will add an option in FxSound settings UI.

1 Like

I have this problem too

1 Like