FxSound Crashes when switching outputs

As the title implies, whenever I open FxSound, it will crash after switching the output device. But it does not crash when switching the equalizer template though, just the output.

I know something like this was posted last year, but I already have tried uninstalling and reinstalling this, several times. And I did fix the issue for a bit(few days) by doing this, but now it has resurfaced and doing the same thing isn’t cutting it.

I have also gone into the %appdata% to do a full clearing of FxSound (in the Roaming folder), and that also did not work.

Is there something I can do to fix this? Or something that I’m missing?

1 Like

Hi @Superspeeder. What version of FxSound are you using? Are you getting any error message when FxSound crashes?

1 Like

Hi @bvijay.
I believe I’m using the latest version as of this reply, And I receive no error or any error related pop up upon it crashing.

1 Like

Good afternoon @Superspeeder,
Have you already tried reinstalling after fully uninstalling the driver?
The risks involved in uninstalling the FxSound driver are close to zero, so it might be worth a try.
First, here are the instructions on how to check if the FxSound driver was installed properly:

And here are the instructions on how to manually delete the driver:

This is my standard list of settings I usually recommend checking first:

  • Make sure your computer, Windows and sound drivers have received all the latest updates;
  • Try browsing their manufacturer’s website to find and download software built specifically for your devices;
  • In the General section of FxSound’s Settings menu, try changing the setting for automatic switching;
  • Try completely removing and then re-adding the problematic sound device(s);
  • Try running FxSound as Administrator;
  • In the Windows Sound Settings menu, make sure all your devices match at the same setting, with “24 bit 48000 Hz” being the maximum supported by FxSound;
  • In Windows Sound Settings, make sure the FxSound device is set as the Default Device;
  • If this doesn’t improve anything, try setting FxSound as the Default Communications Device;
  • In Windows Sound Settings, disable all Enhancements including Loudness Equalization for all devices;
  • In Windows Sound Settings, disable Exclusive Mode for all devices;
  • In Windows Sound Settings, disable Hardware Acceleration for all devices supporting this option (can usually be found in the Advanced tab);
  • In Windows Sound Settings, disable all the devices you don’t need, including the hidden ones;
  • Try downloading the program from a different source and installing that version instead (if you’ve downloaded from fxsound.com, try downloading from the Microsoft Store and vice versa);
  • Check the Changelog to find the closest previous version fit for your needs, and try installing that instead (more of a last-resort option to try if all else has failed);
  • Try uninstalling with specialized full uninstaller software (not an obligation and also more of a last bet).

I have tried uninstalling the driver(and reinstalling it), and I have also gone through almost everything in your checklist. But it still doesn’t fix the issue. I am able to switch outputs, but it still crashes. But rather it crashes a second after rather than immediately after switching.

The only one I haven’t touched is the version rollback. How exactly do I go about doing that?

1 Like

Uninstall via Control Panel, download the version you wish to install, and run the .exe.
(You were right to ask though, since running the .exe of an older version simply makes a pop-up appear stating that a newer version is already present; sorry about that.)

Thanks for the heads up! But, I’m wondering how to download the older version in the first place. Since the only download-related button in the changelog is just one for the newest version.

1 Like

I included a link in my post for that purpose:

Guess I apparently never “saw” that link in there. That’s my fault.

I’m just not understanding though where I would go to download the older version(s). I can see the version changes but that’s just about it. Is there something I’m forgetting here?

1 Like

Good point - touché! :sweat_smile:
That’s my mistake, sorry 'bout that.
I’ll do my best to find another site that actually has them.

NeoWin dot com has

All the other versions I’ve tried there refused to download though…

All of these are valid and free downloads.
Ignore the first numberless one, it’s the same as the second one, v1.1.19.0.

Thanks for the links! Though unfortunately, that still somehow hasn’t fixed my issue. I’ve downloaded both the .18 and .17 versions and even went down to the .14 version, all of which still experience the same issue. Is there anything else I can try to fix this?

1 Like

@Superspeeder’s issue is still present, so I was hoping you might have some more troubleshooting suggestions…
Thank you.

Ok, so I wanna give what might be a long, but interesting update on my issue.

So I somehow managed to accidentally but not accidentally fix the crashing issue. All I did was click the red power button in the application before switching outputs. After I did so, I turned it back on and it was running perfectly fine. It did crash after switching to another output device after the power button thing, but after I re-loaded FxSound, I was able to switch through outputs with the button on just as I normally have before the whole crash situation arose.

I did however roll back to v1.1.17.0. But that’s just because my audio sounds quieter on the newer version than it does on the old one. For example, my audio at 20% volume is louder on 1.1.17 than it is at 20% on 1.1.19. And that’s just the way I was used to it. I may move up to 1.1.18 if it works the same as 1.1.17. But otherwise, I can just stick with 1.1.17 until another update and try upgrading then.

I’ll just have to hope this isn’t a temporary thing and that it will be permanent this time.

1 Like

Weird, and thanks for letting us know.

Glad you found a fix, for now; but could I kindly ask you to share a list of the audio devices you are using?
I figured, since the problem only occurs when switching devices, there might be a more elegant solution here that we’re simply overlooking.

So another update with that fix: The fix I had kinda works on and off. Yesterday after doing my fix the application worked fine. But today, the crashes still occur, and doing the fix is kind of a hit or miss with whether or not it crashes. Anyway, here’s that list:
Screenshot 2023-07-21 125929

1 Like

James did mention that,

I installed VoiceMeeter Banana a while ago, and started getting weird errors.
So I ended up disabling the VoiceMeeter devices in the Sound control panel.
I would similarly suggest disabling any and all sound devices (audio ànd recording, and hidden ones as well) that you never, or hardly ever, use or need.
Of course, your priorities are completely up to you to decide; but in this case, and lacking other troubleshooting options, I’d say temporarily disabling the devices you can do without during most of the time you use your computer, seems like the smartest precaution to take, if you want to avoid errors while enhancing audio with FxSound.