Switching playback devices

I switch between headphones, speakers, and a headset. Before installing FxSound, I did this with Volume².

With FxSound installed, it seems that sometimes the playback device switch works properly when I use Volume², and other times, it doesn’t.

Is this a bug, or is FxSound simply designed to require that it and it alone is used to switch devices?

1 Like

My guess would be that this is indeed the case.
FxSound works as a virtual sound card, which is why it needs to be set as the Default Device, and allows it to boost all audio on the system.
If you install a second program with a similar role, it seems logical that conflicts will arise.
Give me a minute to visit the link you shared, because I’ve never heard of this software before.
FYI, most users report no errors when combining EarTrumpet, a similar volume control app, with FxSound.

Volume² isn’t setting up any virtual devices; it’s just switching between existing ones. To me it seems feasible that FxSound could detect that the active device has changed and then to account for this change, but I wasn’t sure if it was indeed designed that way. This was the basis of my question.

I mainly like having an easy way to change the volume and for the volume to be forced to 0 when audio devices are switched. Changing audio devices via hotkey is nice, though. I will look into EarTrumpet.


1 Like

I do not know the answer to this question, but I am willing to forward it to the lead audio engineer, if you want.

I’d appreciate it. Thanks!

1 Like

No problem. Message sent.

Hi @Scott
For FxSound to work, it has to be the default audio playback device. To output audio to the required device, we have to select the device from FxSound. Volume² switches the default audio play back device and FxSound is not the default device after the switch then FxSound does not work.


It actually seems to cooperate nicely with Volume² if “Automatically switch to newly connected output device” is disabled. I don’t understand why, but I’m happy with it.

Thank you!