Selectable "Default Communication Device" instead of "Default Device"?

I read in other topics that fxsound needs the locking of the Windows “default device” and cannot be switched to another “real device”. But may there be any chance to get an option to select this locking between the “default device” and the “default communication device” ?

As a virtual pilot, I use Prepar3D by Lockheed Martin as my flight simulator and a tool “Pilot2ATC” for flight communications.

Today, I found your plugin and it enhances immersion by filtering the Text-to-Speech output below 1 kHz and above 2.5 kHz, the answers from Ground, Tower an Center sound more like a real VHF radio.

So,P3D environmental output (engine, prop sounds) is set explicitly to the Realtek mainboard output → my speakers, now I changed Pilot2ATC’s output to fxsound and fxsound output to my Sennheiser headset for aircraft radio communication.

So no problem for flight simulation. But as fxsound has to go to my headset for this simulation, all other programs (games, webbrowser) runs also into my headset - until I switch fxsound back to my Realtek mainboard connected speakers.

And for flight simulation, I have to switch fxsound back to my headset.

So my suggestion is not to disable locking at all but to make it switchable between the default device (in my case the speakers) and the default communication device (in my case the headset).

1 Like

Good evening Kevin,
I think setting FxSound as the Default Communications Device should be possible without causing any difficulties.
It’s actually a bullet point of advice in my standard troubleshooting list, to try setting it as the Default Communications Device, in case setting it as the Default Device is problematic.

1 Like

I wasn’t able to set fxsound as “Default Communication Device” as it always locks itself to “Default Device”.

My thought wasn’t to set fxsound as “Default Communication Device” but instead fxsound using “Default Communication Device” for its locking mechanism,

My intention was to keep my Realtek HD Audio output as the “Default Device”
and fxsound using the “Default Communication Device” for its purposes. But it doesn’t work, fxsound grabs the “Default Device” no matter what I do.

1 Like

As far as setting FxSound as the Default Communications Device, my guess is that if you do so, it sets FxSound as both the Default Device ànd the Default Communications Device simultaneously, but, shows it named only as Default Device in the sound settings.
Your idea has been suggested before, but unfortunately, that’s not how FxSound works, and it could simply never work under that condition no matter what you or anyone else tried.
The basic axiom is that in order for FxSound to be able to process any audio, it must always be set as the primary, Default Device; and if this condition is not met, then no audio can or will be processed by the driver.

Uninstalled and testing DeskFX.
“I don’t know where I’m going, but I sure know where I’ve been…”

1 Like

Posted by a helpful user,