FxSound constantly set itself as default device


Despite changing another device to default, FxSound set itself as default immediately.

Is there any way to disable this?


1 Like

Hi Jackzy.
FxSound has been described as working as a virtual sound card through which audio is processed, and is not your actual output device.
In Windows Sound, you can disable the FxSound Speakers device as long as desired without any harmful consequences, but it needs to be set as the Default Device if you want the FxSound Audio Enhancer driver to process your system’s audio.

I understand it needs to be set as the default device if i want the processing and that’s not a problem.
The problem is that the app set itself as default constantly.

If the user willingly set another device as default, it probably mean he doesn’t want processing done at that moment.

Why would the app overtake that decision?
I wasn’t expecting FxSound to be that invasive, specially in windows where users usually have plenty of freedom.

If a user has “audio device 1” set in FxSound and set “audio device 2” as default device in windows, the audio will go through “audio device 2” but will be processed by FxSound, while still showing “audio device 1” in FxSound ui.

Since the app itself doesn’t have memory settings to remember which audio device should be processed or not, and no shortcut for specific audio device, the user has to use the shortcut to scroll through different device until he find the one he want and then use another shortcut to turn it off and on every time or alt tab and go to the fx sound icon open it and make the adjustment.

Upon installation i was expecting to just set FxSound with the audio device of my choice (my speakers) and have the audio device on my headphone remaining unprocessed.
press 1 key and FxSound is set as default device output to my speakers
press 1 key and my headphones audio device is set as default unprocessed.
Should i require processing on my headphone at that point i would set it on the app.

Clearly is seems like a design decision to have FxSound force itself as default constantly.

Thankfully the app was free and i was able to try out to see if i could use it or not.

I’d like to thank you for your help and explanation.


No worries. I understand your question and your frustration.

I would argue that you can hardly fault the software for automatically setting itself the way it needs to be set; after all, we would be getting way more complaints and error reports in the inverse scenario.

Well, thanks for this. The vision of fxsound beging a virtual sound card is very useful.

I would argue that the functionality @Jackzy wants is actually already in the the current implementation of fxsound, though just differently implemented than expected.

With the shortcut keys you can switch off/on fxsound for the sound device you’re using with ‘a single key’ stroke: the shortcut key for this.

When fxsound is switched off, it still will be your ‘sound card’, but it has stopped processing the sound. Until you switch it on again. Which you can also do with a shortcut key.

Works in my case just fine. I mean, once in the fxsound settings you’ve set the shortcut keys to the ones that’ll work in your implementation of Windows. This is something you have to manage yourself, since every personalized Windows implementation has it’s specific range of already reserved global Windows shortcuts that only you can know and only you can adapt.

The only thing I would like to see added to the settings is the possibility to, yes, start fxsound at startup, but start it up switched off. Because I don’t see how I could make it doing so in the current settings options (without hitting shortcut keys after startup).

1 Like

Currently, either turning the main Power button off, or selecting the Default Preset (with zero processing), before shutting down your PC, seem like the two closest options to that outcome, since the program remembers its last state.