Audio is mute at first

Whenever I turn on my computer, I initially get no audio, despite FXSound waves. Only closing FXSound and reopening it fixes this issue. Any ideas for how to prevent this?

1 Like

It’s also annoying that the fxsound card stays assigned. I have to change the device or turn off the FxSound Speakers device. When re-using, I turn on the device, if I turned it off, because the program does not know how to manage the state of the device itself (turn it on when the program is opened and turn it off when it closes).

Correctly, the status of the device should change connected / not connected depending on the activity of the program, and now the device is always active.

1 Like

Sorry you have to deal with it too. If you find a fix, I would love to know about it.

1 Like

Hi Blushock,
Welcome to the forum.
Have you tried disabling automatic switching in the Settings menu?
I’ll call in @TiM for further troubleshooting ideas.
Good luck.

In FXSound Settings or Windows Settings? Because I don’t see an automatic switching setting in FXSound Settings. Would be awesome if u could provide a screenshot

1 Like

Disable this and let me know if it helps:

Somehow, it was already disabled. At any rate, I can just close FXSound before putting my computer to sleep and set it to NVIDIA High Def Audio. Then reopen it as needed.

1 Like

Okay, so this did not solve your problem then.
@TiM: Can you assist, please?

This is a weird bug and the first I’ve heard of it.
Have you set FxSound as the Default Device in Windows sound settings?
Have you already tried to fully uninstall with specialized uninstaller software and then reinstalling?

Specialized uninstaller software? And yes, FXSound is the default software. Seems like this could be easily fixed if there was a way to manually select the default playback device in FXSound.

1 Like

Yes, like IObit Uninstaller Free.

I just got BCUninstaller.

1 Like

Alright that seems to have worked. If it pops up again, will exit it before going to sleep. Thx for the help.

1 Like

No problem.
If the issue returns, please post here again, and we’ll look for further troubleshooting options.

Thanks, Dolmatov.
@bvijay: Please take a look at the user feedback below,

If you have a default playback device selected in system tray or through control panel as your speaker or headphones, then when FxSound is launched the control will switch to FxSound and when you exit FxSound, the audio playback will automatically switch back to your speakers.
Please let us know if you see a different audio behaviour in your system.

1 Like