FxSound changes my output device all the time in Windows

On Win11 my standard output device is “Speakers”.
Since I Installed FXSound there is a new standard device “FXSound speakers”. Now whenever I start Windows I have to go to setup and click on speakers to get some sound. This is very annoying because I am working on remote. What to do to keep my own standard device?

1 Like

Hi Warthog,
Just to be clear: you mean you’re working with Remote Desktop, yes?
There have already been multiple threads on this topic in the past, like:

In normal scenarios, FxSound needs to be set as the Default Device at all times if you want your audio to be processed by it; in other words, there is no way to not have FxSound selected as the Default Device, and still get audio processed by FxSound.

FXSound is my standard device, but to get any sounds I have to go to setup and click on speakers (my original standard). This is always when I start new. I just want to avoid this annoying extra click.

1 Like

Sorry, wrong explanation.
I sit on my sofa watching TV, windows is always running in the background. So by remote I click on my receiver to get music from the pc. No sound. So i have to stand up, go to my computer and open setup, click on speakers (my original standard) and then it works.
I just want to avoid this annoying extra click. And this happenens every time I start the computer new.

1 Like

Thanks for clarifying. Your opening post did not mention anything about trying to combine a Windows computer with a television set. It is still unclear to me, whether you are having difficulty getting audio from your TV to play on your speakers, or having difficulty getting audio from your PC to play on your speakers?
FxSound was created to run on standard installations on Windows. It was not created with the combination of PC and TV in mind. Which isn’t to say that the combination is impossible, only that this introduces an additional layer of complexity, and that this makes the possibility for the occurrence of problems more likely (up to the point of a possible device incompatibility, which is not the case here).
Also, could you please supply more details about the devices used? For example, could you clarify what device you are describing as the “receiver,” which speakers you are using, and which television set?
It’s also a good idea to consult your device’s manuals or support pages on their manufacturer’s website, to learn more about the possible cause.
There is a troubleshooting list bannered to the top of the forum, which no one ever seems to be able to find or consult; it would be helpful if you could run through that first, to verify proper setup, e.g., make sure you have the latest version installed, that Exclusive Mode is disabled, et cetera.

Ok, here we go:
I have a win11 computer that is connected via HDMI to a Yamaha receiver and then to a Samsung TV.
the set works fine and I can change from TV programs to films on my computer just by changeing the input source on the receiver.
Bevor I installed FXSound all the pc sounds came from my pc speakers and the speaker set (Teufel) of the receiver. They always copy the sound from the pc speakers.
Now whenever I start Windows I have to go to setup and click on “speakers” to get a sound. FXSound still stays standasd devive.
Yes I’ve read the troubleshooting list and the only thing was “automatically change to a new device”. I swiched this off and it seems to work.
Let’s see if it stays stable.

1 Like

Thanks for the info, and happy to hear there is some improvement.

In Windows Sound, is the output device changed to a different device instead of the Speakers device; and, is it a desirable option to disable that device?
That would provide another simple solution to the problem.
There have also been some issues previously reported with HDMI connections, you can look those up by typing the search term “HDMI” into the looking-glass dialog box at the top right of the forum.

I have the same problem but am using a standard Windows 11 computer with a regular monitor and speakers. I’m using Audioengine 2 speakers and every time I reboot I have to click on Audioengine 2 as the source then it switches back to the FXSound Audio Enhancer automatically but starts to work. Then randomly throghout the day it stops working and I have to do it again. I’ve tried setting ‘automatically change the source’ on and off and no matter what I do I’m left having to change my audio source several times a day. Is there something I can do to fix this? Happy to help troubleshoot and it’s possible the solution for me will work for the HDMI sources as reported by others.

1 Like

I’ll add something that could be contributing to the problem. I do work from this computer and we use (and manage) our Citrix DaaS Virtual Desktop solution. This maps the default sound source into the remote computer. Seems like it would just map the FXSound source and work the same without changing the sound input for FXSound but I’m not an expert on this.

1 Like