No sound only after awakening from sleep

Currently using FxSound 1.1.15.0. Since 1.1.13.0, if my Dell XPS 8930 desktop computer is put or goes to sleep, FxSound mutes all sound on reawakening. I have to restart FxSound to get sound back (exiting gets it back). I use Windows 10 Pro (always the latest) and use Bluetooth speakers (Edifier). I suspect the issue is Bluetooth. (I am vigilant about keeping all of my drivers updated.)

I have disabled all other sound devices - Realtek and Intel. In Device Manager, the only audio inputs listed are FXSound Speakers and Speakers (Edifier 1850DB Stereo). I have read the “no-sound-with-fxsound-realtek” page in your learning center, but the directions don’t seem to apply to me. Again, I get sound with FxSound, just not after awakening from sleep.

This is not a major issue, which is why it’s taken me so long to ask for assistance. Do you have any ideas for fixing this? Thanks!

1 Like

Hi Teach,
The first and most obvious road to travel, for me at least, would be to adjust the sleep timer in your Power Plan, to make sure your computer stays awake longer, or always…
Also, since you’re only using one speaker set, it would be wise to uncheck the option to automatically switch in FxSound’s Settings menu, if you haven’t done so already:
image
Next, I would recommend to look for hidden devices in your sound settings and to make sure they are disabled as well.
Apart from that, I regret to inform you that there is no known fix for this issue yet.
Good job on all the proactive measures though, I must say.

1 Like

Thanks for your prompt response, doolhoofd. I took your advice to uncheck “automatically switch” and I’m on my way to check for hidden devices. I’ll let you all know if anything changes because of the tweakings.

1 Like

Please do; I’m sincerely curious if my advice helped you or not.

Mine does the same thing, but I only ever manually enter sleep mode. Let us know if you figure it out.

1 Like

Same issue here. Affects both my Windows 10 laptop as well as my Windows 11 desktop. Can’t seem to find a solution and it’s driving me crazy. It’s very annoying having to manually exit and re-launch the application after each wake-up, especially on the desktop which is a living room tv PC.

1 Like

OP here. I’ve tried a few solutions to no avail. I used sleep after a few minutes for security (require PIN on awake). Using a screensaver with “on resume, display login screen” lets me lengthen the time before sleeping, but nothing fixes FxSound being mute on waking once my computer sleeps after a few hours.

1 Like

@TiM: Do you have any troubleshooting suggestions for these users?
Thanks!
@bvijay: Do you have any troubleshooting suggestions for these users?
Thanks!

I don’t think i can do much here; if this behavior is directly related to FxSound and can be fixed by restarting the application it seems to have something to do how it reacts to the different stand-by modes of the operating system.

“Normally”, everything should be back to the status it was before any stand-by. However, there are several different forms of stand-by modes and it often happens that operating systems, driver, hardware or applications do not go very well with them. But due to this complexity and many possible sources which may cause this issues it is hard to tell by remote support if this really is “abnormal” behavior of the application, an incompatibility, a specific setting or something completely else.

Seems to be more like a case where we should wait for bvijays answer here since i do not have any insight in FxSounds code and technical functions at all …

1 Like

I wanted to share a simple workaround. Keep in mind that I am not a programmer and this is just a simple batch code I came up with.

Using Notepad I made a text file with the following lines and saved it as .bat.

taskkill /f /im FxSound.exe
cd C:\Program Files\FxSound LLC\FxSound
start /min FxSound.exe

Then I used the default Windows Task Scheduler to run the file on wake-up. Meaning everytime the PC wakes up from sleep or hibernation the FxSound.exe will be restarted. Note that the 2nd line in the .bat file can differ for you depending on where you installed FxSound.

Not the most elegant or ideal solution, but I hope this helps!

2 Likes