Microsoft Store version not updating past (doesn't show in app list)

I recently got a new motherboard which has different audio (still realtek of course, but different otherwise) so I uninstalled FXSound and reinstalled after all new/update drivers were installed.

I went to the Windows Store page, clicked install, and everything is fine.

However, I notice my version number is, as well, the app does not show in my list of installed app, ignoring that, nor does hitting the button that would check for updates for all installed apps.

I have messed around with sorting/filtering of installed apps, and even totally reset the MS Store, but nothing changes.

Has the app been frozen on the store in some way (like we must access the site version for anything newer and use the built-in updater over the store version using the store for update) or is this a submission/certification issue - my other apps, such as ear trumpet, are not having this issue.

1 Like

Good evening,
I have no idea, but I’ll forward it to the team.
Thanks for reporting this.
I hope getting v1.1.20.0 through the website worked nonetheless?

Have no tried, will just wait for the store version to be fixed or whatever is needed - works great for me.

1 Like

Message sent.