High Memory Usage

Hi there,

I have been using the latest version of the program (1.1.14.0) on Windows 7 (64 bit) running 4 GB RAM. I have noticed an unusually high memory usage on my PC as seen in the attached screenshot.

Mostly tends to happen when I leave the PC locked for a long time / multiple users use the PC (multiple accounts).

Please fix.

Hello, and welcome.
First of all, please refer to this thread:

Secondly: what kind of fix were you expecting?
This issue could be taken into account when programming the next version of the program.
Fixing the issue on your machine long-distance, however, is very different…

What?

1.1.15.0 Changelog - FxSound

1.1.15.6 (beta) The topic

2 Likes

I would advise to first uninstall and try the latest version 1.1.15.0 and download it here from the official page and retry.

Also make sure that your Windows and especially sound hardware drivers are updated to the very latest version aswell.

When the issues persists, let us know.

2 Likes

Thanks! I did check that but it is the high memory usage in my case and not the CPU usage as seen in the screenshot. Anyway, I see that a new version was already out but sadly the program did not notify me of new updates - something that should be considered by the developers if not already implemented.

Coming to your second post, the expectation is for the developers to re-look at the code and optimize it for the PC configuration as the issue is not at my end but with the program.

1 Like

Thank you for letting me know. It would have been great if the program informs the users about the latest updates.

1 Like

Yes, that is something I will do and let you know if the issue persists. Thanks!

1 Like