FxSound trigger Windows Audio to consume a lot of CPU power when TIDAL output to the same soundcard in exclusive(WASAPI) mode

I assume maybe it’s a case of racing condition of FxSound and TIDAL for soundcard device.
When TIDAL starts playing, WindowsAudio and Tidal begin abnormal consuming CPU.
If I didn’t change output in FxSound for about 10mins, then FxSound will crash, and CPU consumption backs to normal.

Hello Pulsar,
There are already a few threads dealing with this issue, I suggest you check them, perhaps they can enlighten you.

Also, this thread.
User tried WASAPI, apparently it is incompatible with FxSound?

Hi, doolhoofd, I checked the topics mentioned in your previous comments, but none of these is the my case.
Let me explain what I trying to do:

  1. I choose my USB soundcard in FxSound, which I prefer use for listening, in current moment. Then open browser and watch some Youtube. Everything working as expected.
  2. After that, I close tabs with multimedia content in browser, open Tidal, choose thw same USB soundcard as output device, as in FxSound, because I wish Tidal use the soundcard exclusively, stream music to sound card directly, bypassing the FxSound. In TIDAL I flag “Exclusive mode” and “MQA passthrough” options.
    After that, I push play button in Tidal, this situation happens:
    image
  3. Then if I open FxSound, I can see message like:
    “FxSound unable to process audio through the selected output device…”
    At the same time USB Soundcard still selected as output in FxSound.
  4. Then if I change output soundcard in FxSound to another one, CPU usage of “Windows Audio” and Tidal back to normal.
    It’s a little bit annoying to do so every time when I open the Tidal. Also if I forget to change output device in FxSound when Tidal playing music, after ~10mins FxSound will crash…
1 Like

Okay, so, first things first:
I’m not a tech guy, I can’t solve this.
Let me call in some assistance.
@bvijay: Could you please look at this thread and offer user assistance?
Thanks.
Secondly, have you tried simply toggling the main Power button of FxSound to “OFF” when listening to music through Tidal?

Yes, I tried to toggle the “Power Button” in FxSound, it it didn’t help.
But if “Exit” FxSound application, this problem will not appear.

I summoned FxSound’s lead programmer, he should be here soon.
Sorry for the wait.

Sorry for the delay in my reply.
If exclusive mode is enabled on the audio output device, and another application is already using the device then FxSound will not be able to use the same device to stream audio.
If exclusive mode is not a mandatory requirement to use TIDAL, please disable exclusive mode in the USB soundcard to let FxSound to access it.

1 Like