High power consumption

With fxsound active, battery usage is 2-5 watts higher at all times. Is this expected behavior? This reduces my laptops runtime in half.

1 Like

Hi,
Could you please first share which version of FxSound you have installed?

The latest, 1.1.20.0

1 Like

Okay. Thanks.
No, that is not normal behavior.
Give me a minute to look into this.
By the way, this is off the topic of FxSound itself, but I made this post on conserving laptop battery life a while ago; it might also be useful to you.

If it’s helpful, I’m running windows version 23H2 on a ryzen 7940hs asus laptop.

1 Like

Here’s the list I’ve compiled.

Questions:

  • What Power Plan do you use regularly? And, at the risk of stating the obvious: have you already tried changing these settings? You can change them in your Power Manager application, or in Control Panel > System > Power Options.

  • Could you please take a look in Task Manager’s “Processes” tab and share the percentage of CPU use FxSound is taking up while On? It’s easy to sort the processes in descending order by clicking on “Memory” on top.

Note:

  • A computer’s Graphics Processing Unit, a.k.a. graphics/video card, usually consumes a lot of power when active. (You should find the model installed on your laptop in Device Manager, under “Display adapters.”)

Suggestions:
In Windows Sound Settings:

  • Disable Exclusive Mode for all devices;

  • Disable Hardware Acceleration for all devices supporting this option (usually found in the Advanced tab);

  • Disable all devices you do not need, including any hidden ones (done via “Don’t allow” in Windows 11);

  • Under Communications, select “Do nothing” as the response to Windows detecting communication activity;

  • Try changing the frequency settings of all of your devices in order to find an optimal match-up, with “24 bit 48000 Hz” being the maximum supported by FxSound (changing these settings often makes a bigger difference than you might expect);

  • Make sure the FxSound device is set as the Default Device; and if this doesn’t improve anything, try setting FxSound as the Default Communications Device (this actually sets FxSound as both the Default Device ànd the Default Communications Device simultaneously, but only shows it as the Default Device);

  • Try running FxSound as Administrator;

  • Make sure there is as much free space on your hard drive (C:) as possible: delete or transfer any unnecessary files, uninstall any truly unnecessary programs, and carefully eliminate as many unnecessary programs from startup as possible (these are usually the non-Microsoft ones you can do without with absolute certainty - if in doubt, it’s best to keep the program active);

  • Try defragmenting your hard drive;

  • Try downloading LatencyMon and running a scan while FxSound is alternately Off and On;

  • If the issue is CPU-related, then you might want to check if your built-in fans are working properly, to prevent overheating. You could try SpeedFan, which is freeware (at your own risk);

  • FxSound’s user interface graphics are built on an OpenGL-based framework - but, I checked that, and your laptop supports it.

Please post back with your results, and let me know if this was helpful or not.
In the meanwhile, I’ve also notified FxSound’s lead engineer @bvijay of your problem.

Hi @doolhoofd
You have covered most of the troubleshooting steps.
I would like to add,

  1. Run the command “powercfg /energy /duration ”
    Run the powercfg tool in admin command prompt to get a report on the power issues. Specify the duration in seconds to run the analysis. At the end of the analysis a report will be generated in html format.
  2. Since FxSound uses OpenGL for graphics and OpenGL has to supported and enabled on the GPU, please check the CPU and GPU usage in performance tab of Task Manager when FxSound is processing audio, idle and when audio processing is turned off.
1 Like