FxSound Stopped Detecting my Bluetooth Headset

@bvijay:
Vijay,
Do you perhaps have any advice for @dinasor on how to make the program (re)detect a pair of bluetooth earbuds?
Much obliged.

1 Like

Sure, I will help @dinasor to get the Bluetooth headset working with FxSound.

1 Like

Hi @dinasor
FxSound gets the list of connected audio playback devices from the operating system and shows it for selection. I would like to find out the reason why FxSound couldn’t detect the Bluetooth headset from the playback devices.
Can you please run this command from Windows powershell and share the output,

Get-AudioDevice -List
1 Like

Hello @bvijay !
Thank you a lot for contributing in the help : )
I’ve opened powershell admin and ran the given command, however it can’t recognize it, maybe that’s the problem if FxSound depends on the same command?

1 Like

@bvijay Okay I found that i needed to install AudioDeviceCmdlets module to run it, i did and it showed up the devices.
My “Realme Buds Air 3” appears in the list normally, however FxSound can’t recognize it.

1 Like

Hi @dinasor
Thanks for sharing the audio device list. From this I don’t see the problem why FxSound couldn’t detect “Realme Buds Air 3”.
If you can help us with one more test it would be great. Can you please try downloading and running this utility that we have developed to troubleshoot audio device issues -AudioEnable.exe
It will list all the audio playback devices along with their status - Active/Unplugged/Disabled etc., If you can run this from command line and share us the output it will help us isolate the problem.

1 Like

@bvijay
Unfortunately Windows Defender detects this file as a trojan so it’s not an option for me to open it, but in general the headset is detected normally by the PC, and it’s not disabled as it appears in the sound system.
I can normally hear with the headset only if I quit FxSound and set the headset as the default device in the sound system (which means PC is detecting it normally, unlike FxSound).

1 Like

Hi @dinasor
Sorry that the utility couldn’t be run. I have digitally signed the exe again and shared it AudioEnable.exe
Windows Defender shouldn’t be flagging this as trojan since it is digitally signed by FxSound now.

Even though the audio device is listed in control panel, we would like to identify the issue in the APIs that we use to enumerate the audio devices. In the utility that I shared, all the playback devices will get listed along with the connection status along with the number of channels and sampling rate of the connected devices. So, if you could run the updated utility that I have shared now, please share its output.

1 Like

Hey @bvijay
Just saw the reply sorry about the delay was out of town.
I downloaded the new file, opened it and nothing happened… A quick cmd window appeared then immediately closed, which is also scary for someone who’s paranoid from viruses :")

1 Like

Hi @dinasor, No worries.
The application runs in command line. So, first open a command window with the command “cmd”, and then run AudioEnable.exe from the downloaded folder.

1 Like

@bvijay
Ah okay! Here’s the result, the Bluetooth headset “Realme Buds 3” is recognized normally as active

2 Likes

Hi @dinasor
Thank you for sharing the device details.
The reason for realme Buds Air 3 not getting listed in FxSound is the number of channels. FxSound does not support mono audio playback devices. Is it possible to configure it as a stereo device?

1 Like

Wow.
A simple problem, a simple solution - but such a long and tiresome process to identify it…

1 Like

Hey @bvijay
Thank you for your reply : )
I’ve searched a lot and can’t find a way to change the number of channels or change the Buds to stereo instead of mono.
However I didn’t change anything with the airbuds which probably means that it worked with 1 channel in the past maybe? I honestly don’t know :")

2 Likes

In Control Panel → Sound, can you select your headset then click Properties, and then in the Advanced tab, you can select the audio format and channels.
If you have 2 channel option in the list, you can select it.

1 Like

@bvijay
That’s what I tried at first but it’s greyed out unfortunately
And this same bluetooth headset was working totally fine with FxSound in the past

image

1 Like

If the headset supports 2 channels and not listed in the device properties, you can check with the manufacturer. If any driver is required for the device, you can install it.

1 Like

@dinasor:
Could you please try disabling all the checkboxes which are marked in the above image, for Exclusive Mode and Signal Enhancements, as well as all Spatial Audio options?
And maybe check the rest of the settings under General and Levels too.
It’s quite possible the sample rate and bit depth options might be available to be changed again after that.

1 Like

Hello, sorry for raising this topic before, but the issue is not resolved for me, I have been trying to fix it for a long time and this is what I found out, the bluetooth headset is divided into Headset (one-channel conversational headset) and Headphones (two-channel headphones), in @dinasor you can see that Headphones is unplugged. try to turn it on somehow. I don’t know how to fix it so that the Headset connects, I turn off FxSound when I talk to someone

sorry for the english, this is the translator :slight_smile:

1 Like

This is probably the reason.
FxSound does not support Mono (single-channel) devices.
EDIT - Captain Obvious…