Computer not streaming sound through EQ

I have a pair of Logitech G Pro X’s (Wireless) and I’ve been searching for a way to have more access to EQ presets and better sound quality. When i place the default output device to my headphones nothing happens. When I check settings, output is place on FxSound Speakers.
When I check the audio control panel, audio is playing through my Headphones and ignoring the FxSound Speakers in both the control panel and sound settings.

1 Like

Good afternoon,

That’s normal, since FxSound always needs to be set as the Default Device.

Question: You mention the Logitech doesn’t output sound wirelessly, so I’m wondering if it works with the audio cable attached? And, do any of the other devices output sound through FxSound?

This is a quick copy-paste of my standard list of settings I usually recommend checking first:

  • Make sure you have the latest version installed, v1.1.20.0, available on;
  • Make sure your computer, Windows and sound devices have received all the latest updates;
  • Make sure the headset is selected as the active output device in FxSound’s interface;
  • Try completely removing and then re-adding the problematic sound device (the Logitech headset, in this case);
  • Try browsing their manufacturer’s website to find and download software built specifically for your devices;
  • In the General section of FxSound’s Settings menu, try changing the setting for automatic switching;
  • Try running FxSound as Administrator;
  • In Windows Sound Settings, make sure the FxSound device is set as the Default Device;
  • If this doesn’t improve anything, try setting FxSound as the Default Communications Device (this sets FxSound as both the Default Device ànd the Default Communications Device, but only shows it as the Default Device);
  • In the Windows Sound Settings menu, under the Communications tab, select “Do nothing” as the response to Windows detecting communications activity;
  • In the Windows Sound Settings menu, make sure all your devices match at the same setting, with “24 bit 48000 Hz” being the maximum supported by FxSound;
  • In Windows Sound Settings, disable all Enhancements including Loudness Equalization for all devices;
  • In Windows Sound Settings, disable Exclusive Mode for all devices;
  • In Windows Sound Settings, disable Hardware Acceleration for all devices supporting this option (this can usually be found in the Advanced tab);
  • In Windows Sound Settings, disable all the devices you don’t need, including the hidden ones (the monitor, for example);
  • Since the FxSound driver can be removed with relative impunity, try performing a manual driver uninstall;
  • Try uninstalling with specialized full uninstaller software (not an obligation and more of a last-resort option).

Let me know if any of these tips help.

Lastly: while troubleshooting an issue with a Bluetooth device, FxSound’s lead audio engineer @bvijay recently shared a small .exe that lists all the available audio devices in your system:
AudioEnable.exe (digitally signed version)