FxSound Changes to wrong speakers


I have several speaker choices (Dell, Realtek, Nvidia) in FxSound. The correct choice is Realtek. I choose it and it works fine. However, when I come back or restart, it defaults to Nvidia for some reason. I have Nvidia disabled in Device Manager. Not sure how to make sure it stays on Realtek.

Appreciate any tips.



First logical solution that comes to mind: have you tried disabling the Nvidia device in your Windows Sound Settings yet?

I disabled in in Device Manager thinking that would do it. But it didn’t. I went back and checked Windows Sound Settings and turned that off too. I think they may have done it. Thanks.

1 Like

Glad I could help. :saluting_face:

Hi @Soundchasr
When the PC restarts, it is possible that the Nvidia device is detected before Realtek speakers. You can try selection the option “Automatically switch to newly connected output device” in FxSound settings. This will make Realtek as the default speaker if it is detected after Nvidia.
We are working on a feature to select a preferred device which will remain selected on reboot. Until we make the next release with this feature implemented you can try the option “Automatically switch to newly connected output device”.

1 Like