Chinese language loss and other problems under Windows 7/8 system

Hi, I’m back with feedback again.

There are three questions this time:

Problem 1: Failed to download Visual C++ Redistributable Package

It fails to properly download the Visual C++ Redistributable Package during installation. Although we can skip a question, it affects user usage.

I have manually downloaded and installed it into the system from the Microsoft official page.

Microsoft Visual C++ Redistributable Latest Supported Downloads

Question 2: The Chinese language is lost and cannot be displayed normally

Under Windows 7 32-bit system, some fans and I reported this problem. When I tested it like the example in the picture, it can’t display Chinese language normally.

Question 3: The interface will automatically become larger

When you open the settings interface, if you right-click the tray icon, it will automatically enlarge the UI interface up and down, as shown in the figure.

These issues also exist in Windows 8 systems.In Windows 8 system it can download Visual C++ Redistributable Latest normally. But the Chinese language has the problem of loss.

FxSound works fine in Windows 10 and 11.

I guess the reason for the loss of Chinese may be related to calling the display font. In general Chinese system, it uses Microsoft Yahei font, you can try to unify it.

Or you can use Google’s open source fonts, which are pre-installed at the time of installation.

Hope the above problem, you can fix it. Thanks for your work.

1 Like

Thanks for reporting these issues. We will get them fixed in the next release.
We are using Google Noto Sans Simplified Chinese font. The fonts are copied to %PROGRAMFILES%\FxSound LLC\FxSound during installation.
Is it possible to check if the font files - NotoSansSC-Regular.otf, NotoSansSC-Medium.otf and NotoSansSC-Bold.otf are present in %PROGRAMFILES%\FxSound LLC\FxSound, on the systems where the Chinese text are not getting displayed?

1 Like

You guessed it, Fonts does not exist in the post-installation directory on Windows 7 and 8. It is normal in Windows 10 and 11 systems.

When I manually copy the font into the FxSound installation directory, it loads Chinese normally.

But a new problem arose.

In the settings options, the shortcut keys and tray tips cannot display Chinese properly.

I tried installing Fonts into the Windows Fonts directory and it still doesn’t display properly.

1 Like