Stereo Sound disabled with FxSound

Hello,
I have the following Problem: when I start FXSound, I only get mono sound.
As soon as I quit FXSound my headphones return to stereo sound.
Even in Windows Sound Settings I don’t see a balance Button in the properties of FXSound → Levels, like in the properties of my headphones. (I’m not sure, but I think this means it only can output mono audio).

I verified it with the following youtube videos:

Headphones:

  • Beyerdynamic DT 770 Pro 80 Ohm
  • Beyerdynamic DT 990 Pro 250 Ohm

Amplifier: FiiO E10K Olympus 2

I hope somebody can help me, since I like continue using FXSound :slight_smile:

1 Like

Hi Oss; welcome to the forum.
Have you tried configuring your FxSound’s device to Stereo in the Windows sound menu?
Go to the little speaker icon in the Taskbar on the bottom right; right-click it; click on “Playback devices;” right-click on FxSound; click on “Configure Speakers;” and set it to stereo.
Maybe you can also try the same thing with both headphones, since you’re not using 5.1 or anything like that.
Please report back here with your results.
This is just a first attempt; if this does not help, we’ll need to find a different approach.

1 Like

Absolutely not the case.
You can even widen the stereoscopics with the Surround Sound slider.

1 Like

Hi, thank you for the quick response.
So I tried that for FxSound, but it didn’t work.
My Headphones are connected to an amp and windows sound settings does not offer the option to configure it, even though it works in stereo.

image

I don’t know if it is relevant, but I have Windows 11 Pro installed.

1 Like

Thanks for the quick reply.
Okay, so that won’t work…

@TiM: My idea didn’t work, do you have any?
Thanks.

1 Like

Yes, it is relevant, thanks for sharing.

1 Like

We’ll have to wait until TiM sees his messages.
In the meanwhile, I’ve done some Googling; here’s a report from a user with your amp;

Which leads me to guess that it’s probably a very device-specific bug related to your amp.
And personally, I don’t know any fix for that.

1 Like

Hello @bvijay,
FxSound outputting only in mono here, see opening post.
Any suggestions for troubleshooting?
Thanks.

1 Like

thank you.
that’s something I’ve noticed as well, but managed to fix the issue by turning the amp to max, and the windows volume to about 20% - 30%. But stereo always worked, even when it was unbalanced :slight_smile:

1 Like

Happy to help.
All is not lost yet; the guys I called in know way more about computers than me.
It’s just going to take a little waiting time for their replies to get here…

1 Like

thank you very much for your help. I did not expect help so fast.
I’m happy to wait :smile:

Edit: corrected a word

1 Like

I’m assuming you did everything you could to possibly adjust the settings in the amp’s software; and since the mono issue happens on both headphones, it can logically be derived that the issue is not related to either of those… Mono is certainly not FxSound’s standard behavior… Leaving only the amp as the main suspect of the error.

The program has quite a few weird, surprising, out-of-the-blue and hard-to-fix device- and software-specific bugs… You can find these threads on the forum easily by looking for the red “Get Help”-label. I’m sure your amp’s engineers have a forum as well; if your problem can’t be fixed here, you can still give it a shot there…

[EDIT: Added this link to the FiiO forum: https://forum.fiio.com]

1 Like

Okay, let see if we can clear things up a bit here …

01.) FxSound or its driver is “just” a virtual device; it mimics your real audio devices settings as well. So, when you change the speaker setup or volume level on the real audio device it just does so also.

02.) Your audio devices should be set like this when it comes to default devices:
(Sorry, cannot upload images currently due to a server error; will try later …)
However, FxSound should be your default audio device and your headset your default communication device.

03.) When you right-click the list with your audio devices and from the context menu, select show disabled/disconnected devices to see if there is something hiding which may interfere here somehow.

04.) Disable ALL input/ouput audio devices which you are NOT using! Generally.

05.) It does make a difference if a headset has real (unlikely) or “virtual” surround sound; later meaning, that it is emulated by software only and you do not have more than just a few or even just two speakers in it. However, this does not matter for the Windows speaker setup since it will also display all possible speaker combinations, even virtual. However, on headsets, it often just offers one combination like 5.1 or something.

In the end, i would guess that this is somehow related to the amp. FxSound normally does work directly with the audio devices connected to the computer and itself being between them and the playback already makes things a bit more complicated.

Aside that, there might be configurations on your amp or something we cannot know. Even an incompatibility is possible but unlikely. FxSound is for directly connected computer audio devices and maybe does or does not work with a more complicated, external setup.

Do you see a topic here which brings a new possible solution with it?

2 Likes

Another possible reason on Windows 11.

2 Likes

I’m not using any software for the amp. I’m using the standard windows drivers.

1 Like

Great post! Thanks, TiM! :heartpulse:

Here’s my question: is the amp absolutely necessary for listening?
Because if you can leave the amp out of your setup, …
Well… that would straight-up solve your problem, no?

1 Like

Thank you very much.

  1. Yes this works.
  2. I have FxSound as the default device and my dac as the default communication device.
  3. I don’t have any other software installed that manipulates Sound in any way. The only other devices are, my monitors speakers, which I disabled.
  4. I disabled all other devices, but it did not help.
  5. Sound Settings → Dac Properties → Advanced. I have the Default Format set to “2 channel, 24 bit, 48000 Hz (Studio Quality)”. It only has two speakers and doesn’t have any virtual surround sound features.

I don’t think it is the dac, because my sound is stereo, when I exit FxSound. I only have the problem, when I start it. It doesn’t matter if it is turned on, or not.
Other than that, I don’t use any software for the dac, only the default windows drivers.

1 Like

no, first, because my motherboard can’t drive my headphones, since the resistance is too high.
Second, I tried to use my headphones with my motherboard, the volume was low (since it can’t drive it), but the situation is the same, when I start FxSound I only have mono audio, when I exit it, it is stereo.

1 Like

thank you, it is turned off :slight_smile:

1 Like

Okay; so it’s your machine, and not the DAC.
@TiM: You’re better at this than I am; you know what to look for.

1 Like