Speaker Output Changes to FX on wakeup with no sound

Absolutely. Let me know how I can help.

3 Likes

Would be willing to help for sure.

3 Likes

The same problem. The sound type automatically changes from ‘loudspeaker’ to ‘sound card’ after work pauses. Most recently, the automatic change even happened during the playback of a music track.
Is there a solution in the meantime?

1 Like

@andyk, @Ben, @keg0bass, @Raz, @Heinrich_XI:
Regret to inform you all that there is as yet no known immediate solution for this issue.
Try uninstalling FxSound with specialized full uninstaller software (like IObit Uninstaller Free or BCUninstaller), and then reinstalling.
This appears to be one of the few things that helps to remedy some of the ailments FxSound is afflicted with.

Also, one user came up with a workaround:

Vijay gave this advice:

2 Likes

Thanks to all of you.

1 Like

Here a cross was the solution!

1 Like

I don’t suppose it’s possible to remove all output options except the one I always use- my speakers? The constant losing of the output connection is a real pain these days

1 Like

It is possible to deactivate sound devices you are not using in the Windows Sound control panel, but not in FxSound itself.

Thanks! I wish I’d known this earlier. I don’t think I’ve ever needed anything other than the Speakers (VIA HD Audio) but I had 3 other options and it kept switching to 2450W ( NVIDIA High Definition Audio). Just disabled the others in Sound/Manage Sound devices.

2 Likes

:+1: Happy to help; enjoy!

Hi, I’m a new user running into similar issue where sound stops working.
In my case I turn off the TV (HDMI) to my computer and when I turn the TV back on the sound is missing until I switch it back manually in the FX Sound settings.

Is there a way to save FX Sound to a sound output device so even when its offline it remembers it?

1 Like

@james & @bvijay:
Users are still having the same old issue with sleep mode, and asking for a fix…

@chillout, have you tried unchecking the option “Automatically switch to newly connected output device” in Settings?
This setting will make sure the FxSound does not switch to another playback device when the currently selected playback device is disconnected.

1 Like

@bvijay, thank you for your suggestion.
I’m going to spend some time testing different settings and will report back.

2 Likes

The issue with no sound happens when I turn off my TV (while leaving the computer on) with the Emby Theater app running. The fix is to open the FX Sound settings and turn it off and back on. I tried the same thing with VLC player and it did not disable the sound.
I’m guessing the app I am using is not releasing control of the sound device so FX Sound can enable it again. I’m not sure if this something that can be corrected on the FX Sound side or if I should discuss with the Emby developers about how they access the device. Any suggestion would be appreciated! Thanks

1 Like

Hi @chillout,
Depending on the power management settings in the TV, it may keep the connection active even after turning off the TV. If Windows recognises that the HDMI is connected, then the applications may continue to send audio to HDMI port even if the TV is off.
One thing you can try experimenting is to see how the applications behave when you physically disconnect the HDMI cable.

2 Likes

@bvijay,
Thank you for the suggestion. I think this issue has been resolved for me and may have been a driver issue with my video card or me messing with power management settings. My old video card was an AMD R9 380 running legacy drivers. Since upgrading to NVIDIA RTX3060 using modern drivers the sound works upon turning on the TV.
I appreciate your helpful suggestions and the functionality this software provides for enhancing the TV audio experience for me and my family.

1 Like

Hi @chillout
Happy to help you and we are glad that the issue is resolved and audio on TV is working for you as expected.

1 Like