FxSound switches audio devices after sleeping. How to stop?

I have donated to FX Sound as I think it a decent program and helps the poor audio coming directly from my laptop.

Because my laptop is connected to a stand-alone monitor via HDMI cable, the monitor now has sound capability (which I don’t need or want). I set my setting to “Headset out” and everything is fine. Then the laptop goes to sleep and the next time I play any sound FX Sound switches automatically to the monitor’s speaker (which sounds like crap).

I want to set FX sound to recognize the headset out port on my laptop and nothing else. How can I make it happen and get it to stop switching devices?

2 Likes

Hello Vindi;
We’ve seen this problem before, see thread linked below.
But user @TiM has proposed the most elegant solution so far: simply disable the monitor in your Windows sound settings.
Elsewise, have you tried disabling automatic switching in [EDIT: FxSound’s] Settings menu?
Here to help,
doolhoofd

If all else fails, you could still simply change the settings in your Power Plan to stop the laptop from going to sleep…

There are some changes in output connection handling in the latest beta release shared at http://download.fxsound.com/beta
Uncheck this option in settings
image
If the selected playback device is disconnected on standby/resume, then FxSound will not switch the output. If the same device is connected back, then playback will resume on that device. Otherwise, to change the output choose a different playback device in FxSound.

2 Likes