Install issue - Wont select as output

Hey all, I’m trying to download on Windows 11 and it seems to install fine but when I select it as output it constantly (and rapidly) flicks back and forth between the Fxsound and my inbuilt audio ultimately giving me no sound. I’ve installed and uninstalled a few times but it keeps happening. I used Fxsound on my old laptop just fine so I’m not sure whats going wrong

1 Like

Good evening Annabelle,
Apologies for the trouble.
I’ll alert FxSound’s lead audio engineer and post my standard list of settings to check below…

  • In the General section of FxSound’s Settings menu, if you don’t need it, please try unticking the box for automatic switching and see if this improves the situation;
  • Make sure your computer has received the latest updates;
  • Try running FxSound as Administrator;
  • In Windows Sound Settings, make sure all your devices match at the same frequency setting, with “24 bit 48000 Hz” being the maximum;
  • In Windows Sound Settings, try setting FxSound as the Default Communications Device;
  • In Windows Sound Settings, disable Exclusive Mode for all devices (Playback ànd Recording);
  • In Windows Sound Settings, disable all Enhancements including Loudness Equalization for all devices (except for FxSound which doesn’t have this tab);
  • In Windows Sound Settings, disable Hardware Acceleration;
  • In Windows Sound Settings, disable all devices you don’t use and/or need, Playback ànd Recording, including the hidden ones.

@bvijay: Good evening Vijay,
User @Bells installed the new version and is experiencing issues with the default device settings:

I know you’ve tried uninstalling, but have you already tried manually removing the driver?
First, here are the instructions on how to check if the FxSound driver was installed correctly:

And here are the instructions on how to manually delete the FxSound driver:

Also, as mentioned above:

Please exercise care and caution when messing with drivers.
As far as I know, the FxSound driver can be removed with relative impunity; but the same cannot be said about other devices.

Hi @Bells,
Did you upgrade to the latest version of FxSound or are your installing FxSound for the first time?
If other audio enhancement applications are also present, multiple applications trying to enhance the audio stream can cause issues.
In the playback device properties of your speaker please make sure exclusive mode and audio enhancements are unchecked.

1 Like

I think I’ve tried everything I can that you’ve suggested and I’m still not getting anywhere. I’ve uninstalled and reinstalled a few times (and gone through and gotten rid of any file associated with it before reinstalling). I’m not quite sure what to do as I am a bit nervy about messing with things (at one point my default speakers disappeared). I managed to get it to stop flicking between them at one stage, but it wouldn’t let me adjust any settings and when I tried to open the program it came up saying the settings file wasn’t found and wouldn’t open. Not quite sure what to do next. I’ve also tried downloading it from the Microsoft store which didn’t change the result

1 Like

I found this thread concerning the Settings file:

…Any luck?
Did that thread on the Settings file help you?

Heya, so sorry I thought I had gotten back to you! I still haven’t had any luck so I’m not quite sure what to do

1 Like

Good afternoon Vijay,
User @Bells is still experiencing the same issue with default device settings.
Do you perhaps have any other troubleshooting suggestions she could try?
Thank you.

Hi @Bells
Can you please see if this file created after installation %PROGRAMDATA%\FxSound\FxSound.settings

1 Like

Hey there, I’m not the most tech savy so I may not be searching correctly but when I search my PC for the file there aren’t any matches. I’ve installed and uninstalled the program probably close to 10 times and I’ve also tried downloading the old version but the same thing happens. I’m pretty sure I’ve tried all the trouble-shooting I’ve been given so far so I’m not sure what else to do.

1 Like

Enter this in File Explorer

You should get this file listed,

1 Like

thanks for getting back to me! That file does exist but I can’t do anything with it, it also looks like it’s from a previous install as the modified date of the file is a few months old whereas I only just redownloaded it now. I’m also only able to open the program itself if I do so as an administrator but even then after a minute or so this pops up and I have to close it. I’ve attached a gif as well of my sound settings and what happens when the program is installed


[video-to-gif output image]

1 Like