FxSound Stopped Outputting Sound

I just started using FxSound recently through the Microsoft Store version and was enjoying the much improved sound quality and volume. Today when I booted my PC the equalizer would close itself anytime I launch it. It would disappear from the system tray after a few seconds. So I checked for updates and there was one I attempted to apply which failed and said there were signature mismatches. So I uninstalled it and installed the newest version directly from the site. Now it stays open, but there is absolutely no sound when using it. Going to the sound menu in Windows shows it’s selected, shows activity on the volume meter to the right, but nothing is actually being played through the speakers. I tried changing the Exclusive Mode settings per the troubleshooting recommended by the devs, but nothing worked. The same issue applies if I change my audio drivers from Windows High Definition Drivers to Realtek. I’m losing my mind here ha. This worked wonderfully for almost a week and just broke. I haven’t changed anything on the system either. No new updates or anything. Any and all help is super appreciated!

1 Like

Good afternoon Roselle,
The first thing I would recommend, is reinstalling the software after first having fully uninstalled the driver manually (since the risks involved in uninstalling the FxSound driver are close to zero).
First, these are the instructions on how to check if the FxSound driver was installed properly:

And these are the instructions on how to manually delete the driver:

Next, give me a minute to look up my first-aid-kit list…


  • Does the sound return after you’ve switched the power button to Off?

Off button

  • Does the sound return after you’ve disabled the FxSound device in the Windows Sound Settings menu?

This is (an abbreviated version of) my standard list of settings to check first:

  • At the risk of mentioning the obvious: try checking all volume sliders in your system - there are usually many, in several different places;
  • In Windows Sound Settings, make sure all your devices match at the same setting, with “24 bit 48000 Hz” being the maximum supported by FxSound;
  • In Windows Sound Settings, make sure the FxSound device is set as the Default Device;
  • If this doesn’t improve anything, try setting FxSound as the Default Communications Device;
  • In Windows Sound Settings, disable all Enhancements including Loudness Equalization for all devices;
  • In Windows Sound Settings, disable Hardware Acceleration for all devices supporting this option (can usually be found in the Advanced tab);
  • In Windows Sound Settings, disable all devices you don’t need, including hidden ones;
  • Try running FxSound as Administrator;
  • Check the Changelog to find the closest previous version fit for your needs, and try installing that instead (more of a last-resort option if all else has failed);
  • Try uninstalling with specialized full uninstaller software (not an obligation and also more of a last bet).

Please let me know if any of this helps at all.

Concerning the driver uninstall…
After going through this process myself just a minute ago, I wanted to add that, firstly, you’ll have to restart your computer; and secondly: after uninstalling the driver, you’ll probably still want to check your Control Panel (under “Uninstall or change a program”) to verify if FxSound is uninstalled there; and if not, uninstall it through Control Panel as well - before reinstalling.

My apologies for all of this being overly complicated.

Okay, so I tried using the power button and even with the power button off I get no sound. My sound setting are at the 24bit 48000 Hz. I did go through and uninstall everything, gave it a restart and checked to make sure it was no longer listed in the Control Panel Programs section. I even went through my C: drive checking that all the folders and files were removed. I did a reinstall and I still get no sound when using FXSound. I’ve now also tried a different Equalizer (Boom 3D) and that equalizer works fine. I am still trying to use FXSound though as it’s a superior equalizer. Just kinda stuck at the moment since it isn’t outputting any sound. I’ve also noticed that when the running it as administrator does keep it from closing itself in the system tray temporarily, when it’s running as the default device I cannot expand my audio source tab on the Start Bar and hitting mute on the Audio DropDown just causes mute to blink on and then back off. It’s like my system is fighting with FXSound for some reason.

1 Like

User with serious difficulties; troubleshooting suggestions ineffective…
Please assist.
Thank you.

1 Like

Hi @Rosiedreams
Are you seeing the animation in FxSound when playing audio and still not getting output on the selected playback device?
If the volume is set in the system tray icon, please check if the volume for the audio device not low or muted.

If there is no audio in a specific application and if the application has an option to select audio output (For Ex. Zoom), please check if FxSound is selected in the application.

1 Like