FxSound stopped working on my Win 11 system

I have a fully updated Win 11 Pro system:
|Edition|Windows 11 Pro|
|Installed on|‎3-‎11-‎2022|
|OS build|22631.3527|
|Experience|Windows Feature Experience Pack 1000.22700.1003.0|

I installed and used FxSound since 25 March 2024. And it worked pretty much as I expected.
Then suddenly it stopped working a few days ago. When I was intensively working while troubleshooting some issues with my media player of choice, but I suspect that activity as such is not the cause of the issue.
What does ‘stopped working’ mean? Well, it does run. FxSound sits in my tray and stays gray, does not turn purple anymore and it doesn’t output any sound anymore. I still can open it and change settings. When I open FxSound the window is purple, but the tray icon is not.
Total silence, on any output device and with any sound preset I select.
The only way to get audio back, is to exit FxSound.
When I restart FxSound all sounds stop immediately from being outputted to my devices.

I tried all the troubleshooting tips and tricks I could find, including: uninstalled, restarted, reinstalled, manual cleanups etc. In every order I could think of.

I end up with with the same situation all the time:
FxSound doesn’t turn purple anymore, total silence.
Switching Presets or Output device does not remediate the problem.
Changing settings like ‘Automatically switch to newly connected output device’ does not change it, nor enabling or disabling keyboard shortcuts.

In Windows Sound settings FxSound is the default device. Cannot change to another sound device here when FxSound is running, by the way. But my guess is that is how it’s supposed to work. And FxSound is set to the default device for audio.
Also went into the ‘More Sound settings’ option and edited the FxSound Properties here: under the Advanced tab unchecked the Exclusive Mode option. But also this didn’t change any noticeable behavior: total silence all the way.

There is one intriguing thing I noticed:
When I change the playback device. For about 0.1 second I hear the audio output on that device, not longer. After that it is totally silent again.

I’m stuck. Is there a way out of this? Or should I just move away from it and leave it be?


Hi Hans,
I messaged @bvijay on your behalf, since you already tried all the most common troubleshooting suggestions.

1 Like

Tnx for the quick response.
I’ll await his answer.


I got FxSound working again!
I did some fundamental work on my system.
Too many things to summarize, and most of them probably irrelevant.
But my best guess is that the final push to the solution probably was:
Go to Settings/System/Sound/Volume Mixer and Click on ‘Reset sound devices and volumes for all apps to the recommended defaults’.

Hope this tip helps others with similar issues!


Nice! Well done. :mechanical_arm:

Definitely adding that to the troubleshooting list. :hammer_and_wrench:

Thanks for all the info provided. It’s pretty rare for people to make an effort like that.

1 Like

Thanks @Hansk for the detailed information on the issue and the solution. Sorry for the delay in my reply. We are glad that you could find the solution and get FxSound working.


Possibly sort-of related, but under Windows 10 22H2 like a week or two ago I had some issues on one system where FXSound would continously say an error occurred and the program closed itself.

It was strange because before the program was working well in the same configuration, but I think I tried to update it from to where it went wrong with the installer from the website (not microsoft store).

Device manager kept saying there was an issue with the sound device for FXSound and it looked like it had problems with it being a non-valid driver, removing it manually didn’t solve it, microsoft store app I think neither and I even tried removing it entirely using Revo Uninstaller without it being solved.

Later on I resolved that by disabling secure boot for Windows, but if I turn it back on the problem re-occurs as if the driver isn’t a valid signing for some reason. I don’t have this issue on my own machines as I don’t even use secure boot.

But no idea why that is, just thought I’d give a heads-up.