FxSound lowering bg apps volume

hi so I’m currently using fx sound and i noticed some pretty annyoing features dont know if its intended or not. last night when i had a call while gaming, i belive fx sound lowered my game volume to prioritize my caller’s voice, i then test it with gaming while listening to a loud song and sure enough the song was prioritized while game volume is lowered, is there any way to keep this from happening?

1 Like

Hi Felix,
Let me ask @TiM.
Greets

Hi thanks for the fast reply now i might get this wrong because i just “feel” as if its lowered when multiple source of sound is playing so just to clarify does fxsound have some kind of sound prioritize or sound recognition? because i might just over think it really

1 Like

and also im having trouble with checking for update as it just said the sever understood but refuse to do it or sth like that

1 Like

To download the latest version, simply go to Changelog - FxSound.
Personally, I don’t have much of a clue about the technicalities of the program; that’s why I asked TiM. :slight_smile:

1 Like

Most likely you are suffering from one of thos infamous “features” of Windows itself for which the advice since years is: disable it! :wink:

It can be found in the legacy sound devices dialogue on the “Communication” tab and needs to be set to disabled (lowest radio button; should be something like “do nothing” in English). Let me provide a quick and convenient screen:

Okay, file uploads are not working again … -.- Tell me if you cannot find it on your own.

1 Like

thank you i am aware of that option in the communication tab did turn it off before but i guess i still feel kinda off about the audio. However things seems fine now so i guess sth must have worked. Anyhow is it true that Fxsound does not change audio priorities on its own? i just wanna make sure

1 Like

No worries; sound on PCs has been since ever one of those “secondary” topics. Sure, everyone needs and wants it but it is far from being so popular like “performance” or “graphics” discussions — and therefore it is often not that easy to find correct informations or informations at all. I myself am observing and researching some related issues since years and i am relatively experienced.

That said, it also is a topic known for those “felt” issues one may compare best to those with internet connections: is it good? Is it bad? Is the bandwidth high? Or low? How was it yesterday? How is it today? And so forth … there are just that many possible causes on of a kind much less obvious that i can take quite a while to get a little experience with it and track down what seems to be strange. Not that “exotic” as you might think — or “feel” :smiley: — about your issue here!

However, the option we were talking about just gets into action when there are multiple sound sources at the same time, so it could fit your case. I am simply disabling it by default since it makes no good job and therefore haven’t had troubles with it since then. Of course, there are many other possible causes!

Depends on what you exactly mean by “priorities”? FxSound normally does NOTHING on its own aside what you ask of it. One thing which comes to my mind is the option to automatically switch sound devices but that does not seem to fit your case and can easily be diesabled …

1 Like

Hi thanks for the reply now i do think this is fxsound problem i dont “feel” it anymore its pretty clear to me now, because i did test it again with me using discord and gaming and when i say sth long and loud it will just seem to lower the game volume abit then after i stopped it will gradually increase back to the original level, when i disable fxsound it doesnt sound like that anymore things stays the same so yeah im positive its fxsound problem and i just wanna report so im on window 11 if theres no fix to this then i guess i will just have to deal with it

1 Like

To my - admittedly limited - knowledge, there’s nothing that can be done about it.
It’s probably the program’s own automated way of dealing with multiple audio sources.
I’ll ask Vijay…
@bvijay: Could you please give a little explanation about the program’s way of dealing with multiple audio sources?
User is experiencing volume drops and rises when gaming and e.g. using Discord or listening to music simultaneously.
Thanks!

1 Like

I am using FxSound also on Windows 11 Pro x64 21H2 and i am not seeing such issues with multiple audio sources. As far as i know, FxSound itself does not even have such functionality and the only one known to me is the described Windows setting. I think that FxSound is handling every audio source the same way since it is generally set up between your audio sources and your real sound device by its driver interface and has not options about the different audio sources. Your real audio device and its driver, on the other hand, might have those …

However, today each application (including games) often do have several own settings for that. Especially all of the communication applications of whatever kind. My final guess here then would be a setting from one of the applications and maybe you can just do a quick search on the web with combined keywords to see if there is a known issues/function with the applications you use.

1 Like

1 Like

Thanks @caleb59 - good input. :+1:

fxsound does not designate itself as a communication device, but only as the main sound device. Try assigning fxsound to both positions in the window above.
image
It is possible that the operation of the program is broken when outputting sound to two devices. In the Windows mixer for different devices, there may also be different volume levels.
In addition, check the assigned device in the calling program and what happens in the system when a call appears.

1 Like

Thanks for the spontaneous assistance, @Dolmatov! :+1:

still couldn’t solve the problem to this day i dont think this is a window thing because like i said when i disable fxsound things go back to normal so yeah i just have no idea why fxsound is having issues or my window is having conflict with it. just keep lowering audio whenever i start a VOIP call or on discord really annoying

Well, what can I say?
Sorry for the trouble…
Performing miracles is sadly out of my reach…
Vijay is just about the busiest man on Earth right now, so don’t count on an answer anytime soon.
And in any case, there won’t be a coding solution, since the team has more important issues to tackle at the moment.
My best advice is just to turn FxSound off when using multiple audio sources.
Once again, apologies for the inconvenience.
Not all problems can be fixed…

Hi Felix, little late to the party, but I’ve also noticed this on my computer and believe I may have found the culprit, do you have “loudness equalization” on by any chance? For some reason a semi recent windows update made this setting lower background audios that aren’t primarily in use, try checking that off and seeing if it helps

1 Like

Good idea! Loudness equalization might be another cause for something like this. Haven’t ever seen a case where it does this, but being an audio filter which works fully automated and has an effect on loudness, trying that won’t hurt.

Can be found when you double-click the audio device in the Windows sound settings and then on the “Effects” tab in the list. Also make sure you do not have any other filter enabled there; at least for testing.

Also, do check in the other applications since communication devices often do have such options also.

1 Like