FxSound deconfigures the sound of my PC

It already happened to me with DFX, which I once bought and I have its registration number working. The program works very well, improves the sound and everything is fine. But at some point the PC goes without sound and I have to resort to “fix sound problems”. It is very annoying to have to do it constantly. Can anyone suggest me a solution? I have Windows 10 with all versions correctly updated. Thank you and greetings to all.

1 Like

Did you try just re-selecting your output device? This is what keeps happening to me.

Yes, that’s what I do, but you have to do it several times a day and it’s very annoying.

Thanks for answering.

I agree, its super annoying to do multiple times a day. Should be an easy fix you would think.

I’ve experienced a similar issue where FX Sound builds up static and becomes unbearable to listen and just one occasion when it did lost the sound. I used to experience this issue in games such as Battlefield BFBC2/BF3 and most of the time it came down the CPU/RAM resources.

The solution to this for me was to restart the FX Sound application in Task Manager. The sound would return to normal right after. I suspect this releases whatever resources were overflowing and purges whatever buffers have exhausted itself.

For me, in Windows 7/8/9x/10x when the sound suffers from static buildup, I stop and restart the Creative Sound Service and this ends the crackling/humming/reduced volume issues. You should know that in the past Windows 10 would also override the custom drivers with it’s own Windows Update drivers.

I tend to uninstall the default Windows / Windows Update WHQL outdated sound drivers via the Device Manager and favour the one from the manufacturer.

NOTE: If the latest official sound drivers are installed, sometimes uninstalling without driver deletion then allowing Windows to redetect/reassign it after reboot also helps to correct issues. You can reference Google to find out how to stop Windows from Updating and switching drivers to it’s own outdated WHQL defaults.

NOTE: I reboot PC on a regular basis so I wouldn’t experience this sort of issue often due to force of habit and given the need to release a file handle lock for impossible to delete files. I’m aware that terminating Explorer.exe often resolved file locking and such but not all the time. A neat tool to use would be SYSINTERNALS ProcessExplorer tool to find that hidden process thread that’s causing resource spike within the sound driver service or FX Sound application.

I have same problem. This forum shoud have seperate discusion named “Dissatisfaction and
Sarrow of using Windows to listen to music and controling sound”

I use Creative soundblaster XFI Surround 5.1 pro under the control of windows 10 pro because my tiny Logitech X530 speakers, when connected to a computer with an integrated Realtek ALC887 sound card, detect themselves correctly and during a stupid test they make sounds correctly, but later during operation (listening to music playing or watching movies - never mind) only the front + center + subwoofer is heard - and not the rear - never! That’s why I have “XFI blabla 5.1 pro”
Every time when I turning rear speakers louder than others global volume changes to their level. Front speakers and center are set on 15%, subwoofer 10%, rear speakers to 30% (located at twice the distance). Right now global volume is set to 30% and it’s a good volume when my son sleeps in next room and I want to for example watch to movie.

And what? Why is it describing it?

Next day morning I want listen to music when I’m cleaning the flat. to be sure you understand I will describe it in separate steps.
To hear about the lyrics that the artists I listen to I need x4 louder volume than I listen to at night. To do this:

  1. resets the volume in the Soundblaster Entertaiment Console
  2. Then I setting up to 50% of global volume,
  3. I reduce the subwoofer to 40%, because I don’t like when my neighbors listening to music with me :slight_smile:
  4. Set 75% on the rear speakers volume so that it can be heard evenly in the center of the room.
    5 and right now (if I’m not discouraged somewhere in the middle) I can pump up the sound thanks to fxSound.

This procedure is repeated every time I restart, sometimes my Creative drivers crash and hear nothing (these drivers were probably written in Scratch 2.0 https://scratch.mit.edu/ or in the Logo language on the ZX Spectrum Logo (Bits and Bytes, Episode 6) - YouTube and turned out to be a weak port).

Can it be overcome? I’m starting to play with AutoHotKey. On Amiga was Arexx and it was not too difficult - so there is a chance :slight_smile: Joke

I hope that this project will grow to the possibility of such sound manipulations as Viper4Android FX - although I have not used it for several years, fxSound reminds me of it. If we make a group of committed people willing to spend a few bucks and support being here as well, then who knows? Modded windows 13 kernel with DirectX 20 performance pathes and custom Microsoft Store in 6 sizes :slight_smile:

Too complicated for me.
I really like the enhancement effect of FXSound and since I have no alternative, what I do is, every time the PC goes without sound, I go to settings and modify the input. It works, but it is very heavy.
Ideally, someone would find a way to make it all work.

Hi there. Did anybody manage to fix this problem. I use both FX Sound and Desk FX and FX sound keeps defaulting to FXSound speakers, which blocks sound completely. I absolutely love this programme, but I’ve had to uninstall it several times and hope when I reinstall the glitch has been repaired.

I also hope it gets fixed. I really like FxSound.

Is the output changing when the PC goes to sleep and then wakeup. Also if the PC is connected to HDMI monitor and the monitor goes off, the output can change.
If the settings option “Automatically switch to newly connected output device” is enabled this issue can happen with output devices which are not detected immediately after sleep/resume.
Please try disabling the option “Automatically switch to newly connected output device” this will make FxSound to not switch the output and wait until the preferred device is connected/detected.

I have disabled it and hope it works. Thanks, Vijay.

I think it works fine now. I’ll keep watching just in case.
Thanks, Vijay

1 Like

Good to hear that it works now!
Thanks

Another fix to issues like this is to disable unneeded sound devices. That is, only IF they are unneeded, of course! :wink: That prevents unwanted and/or uncontrolled switch to another audio device.

Description

For example, many current monitors add their HDMI-based connections as sound devices in the Windows Device Manager and the Sound Device panels since they also can transfer audio signals. Yet, at least here in Germany, this is still a relativ “exotic” connection not used by many people. However, Windows and/or the graphics driver do install them anyway by default. That often results in an unwanted selection of those sound devices instead of the intended ones like the audio connectors of your sound card or mainboard.

Solution

Simple: go to the Sound Devices panel in the Windows settings and just disable all unwanted audio devices for playback and/or recording. Another setting here, that often causes issues (or at least did in the past) is the automatic decrease of audio devices volume when incoming calls or such are happening. Can be found and disabled here also.

2 Likes

A good tip.
Thank you for your contribution, @PLEASE_DELETE! :+1:

1 Like