No sound when FxSound is running

I am getting no sound whenever the app is open on Windows 10.

  • This has started occurring today. I think it started after removing a headset that was plugged to the speakers. It was an older version, but updating it had no effect.
  • Both Windows and FxSound seem to be registering audio playback. Sliders are moving. I just don’t hear anything, even when disabling FxSound with the button. The app has to be closed for sound to return.
  • Changing to a different audio device, then back to my main one in the app causes audible sound for about half a second.
    (To Digital Audio (S/PDIF), whatever that is. I don’t have anything attached to it, so I don’t know if other devices work.)
  • I installed the newest version several times, both from the website and the Microsoft store.
  • I tried this and that.
    Also turned off all enhancements and exclusive mode.

Tested Modes


  • 2 channel, 16 bit, 44100 Hz (Studio Quality)
  • 2 channel, 16 bit, 48000 Hz (Studio Quality)
  • 2 channel, 16 bit, 192000 Hz (Studio Quality)
  • 2 channel, 24 bit, 44100 Hz (Studio Quality)
  • 2 channel, 24 bit, 48000 Hz (Studio Quality)
  • 2 channel, 24 bit, 192000 Hz (Studio Quality)

Each with FxSound modes:

  • 24 bit, 44100 Hz (Studio Quality)
  • 24 bit, 48000 Hz (Studio Quality)
1 Like

Good evening Christian,
Do you get audible sound after disabling the FxSound Speakers (normally set as Default Device) in Windows Sound Settings?
Have you already tried connecting another device and/or using a different connection method?
Also, did you find the troubleshooting list at the top of the forum?

This is the only thread I found about S/PDIF a.k.a. the Sony/Phillips Digital Interface optical audio connection. This might be off-topic, because I’m not certain if this is related to your problem…

But the information does remind me of this bullet point in the list, which was information shared by our lead engineer:

There are 2 types of encodings, and 2 types of connections. PCM is what a CD player puts out, Dolby Digital is what a DVD player with a DVD movie puts out.
There are 2 types of digital connections: optical (called “Toslink”) and coaxial-digital. Both types of connections can carry PCM and DD signals.
SPDIF (Sony Phillips Digital Interface) is the specifications around which the digital connections are built.

(Copy-pasted from

Ah, I see you added this clarification to your GitHub bug report, but not here on the forum:

Well, since nothing is working, I went back to DFX 12. Which does work.

However, I can’t change any of the sliders. But when I try to unlock the full version with my serial key, the program crashes. Is there anything I can do to unlock it?

Okay, so apparently I was supposed to input the serial number without the e-mail address. Why not just say that?
Anyway, I guess I’m using the old version until someone figures something out.

1 Like

No, all license keys have become invalid.
The incomplete trials are all that’s left of the legacy versions.

Using just the key and leaving the e-mail field blank works for some reason.

1 Like

Okay; if it does work, then I am of course not going to argue about that.

Anyway, thanks for trying to help.
I tried tinkering with SteelSeries Sonar but I just can’t get it to sound nearly as good as with DFX / Fx.
I guess I’ll try going back to the new version again when I reset my system. Or when this one stops working.
You have a good one.

1 Like

I did not know that.
I can actually use this as a suggestion the next time someone asks the same question.


The question wasn’t directed at you. More like the program. :smiley:
I’m glad I’ve found an emergency solution for now.
By the way, is there a way to roll back to an older version of FxSound? Or just the newest one?

1 Like

All older versions (of the purple FxSound) can be found and downloaded for free here:

1 Like

Great. Thanks! c:

1 Like

DFX 12 doesn’t work anymore. I get a message that they need to verify my registration, then it closes. So now I’m back looking for a working FxSound version. I’ve about tried each of the older versions.
Now ideally I’d like to identify where in my driver configuration the error lies, but I’m pretty much at my wit’s end here.

Edit1: I found what I think is an even older version, FxSound Enhancer, which works for now. Although only for the free trial week unless I find my other key (I bought it twice).

Edit2: I found it but when I try to register the correct key it crashes.

1 Like

Sorry for all this trouble.
I’ve notified @bvijay, he usually responds within a day.

1 Like

Hi @Arachnosuchus
Sorry for the trouble that you are facing with FxSound. Are you getting audio through S/PDIF with the older DFX?
If you are using analog audio ports through FxSound, can you please check if FxSound Audio Enhancer is selected as the default device in Control Panel->Sound.

Also please check if the volume is not less or muted in the volume mixer.

1 Like

I don’t have any devices on S/DIF, it’s just an unused port I used for testing what happens if I switch between it and my actual audio source (some speaker pair for LR 3.5 mm).

I just reinstalled FxSound to make sure I didn’t mute it accidentally. lol
Still not getting anything.
DFX/FxSound has been unstable for me sometimes in the past, but it has never taken me this long to fix it. :sadface:

It makes itself the default device whenever the program is running. But yes, I made it the default device with it closed too.

Although interestingly when I test the speakers without the FxSound improvements, but with the program running, I can hear the test sounds. But nothing else. I have to close the program for that. Can’t just disable it in-program.

So I guess it’s back to FxSound Enhancer 13. Except I have to keep reinstalling it because it stops working when I try putting in my key.

And now even reinstalling won’t get it to work (it says it’s checking my registration for like a second, then it closes).

Might have to pirate it or something. If that’s okay with y’all. lol

1 Like