Feature request plus "hiss" issue

Hello :slight_smile:

been using for a couple of weeks and it’s a useful little utility

couple of issues (windows 10 pro system)

some hiss on the effects levels

clarity/ambience/bass - no hiss
clarity/ambience/bass/surround - some hiss
clarity/ambience/bass/surround/dynamic - significant hiss
clarity/dynamic - significant hiss
all 5 - a lot of hiss

the dynamic boost seems to contribute a lot of hiss on its own

a useful setting is clarity+dynamic (helps speech) so the dynamic boost causing hiss creates an issue

another suggest/request

some standard EQ settings have frequency points at 32/64/125/250/500/1k/2k/4k/8k/16k (10 band EQ)

adjusting the dials on FXsound gives the closest to the above as 86/158/293/541/1.01k/2k/4.02k/8.03k/16k (9 band EQ) this slightly misses the bass/sub bass frequencies

would it be possible to expand the dial adjust to give the 32/64 set on FXsound, and to have an 11 band EQ, so that the 32/64 frequencies can be set, plus a 20Hz? (eg 20/32/64)

one last (less important?) thing, could a standard minimize button be added. at the moment it’s ‘compact view’ or ‘close to taskbar’ (which requires an extra mouse click to bring up the window again from taskbar grouped icons)

many thanks

1 Like

Hello. :disguised_face:

There are three main questions here:
a first one about hiss a.k.a. sibilance (there are a lot of tutorials out there which offer help with that);
a second question about the EQ,
and a third about minimizing.

  • On what device or devices are you experiencing the sibilance?
  • Does it occur equally with all devices and connection methods, or only with one specific device?
  • Have you tried replacing some Clarity with a boost to the highest frequencies in the EQ?
  • At what levels of the Effects does the sibilance generally start being audible? They all go from 0 to 10, and as a best practice, it is advisable not to push any Effect beyond its 5th level.
  • Have you checked all the volume settings in your system? (Device Levels and volumes, Volume Control Options, Volume Mixer utility; perhaps also the Speaker Setup Configurator … ) As a rule of thumb, keep all volume sliders below 90%, and never set them to a full 100%. But I’m hoping you already knew that.
  • Have you read the troubleshooting list at the top yet? It contains some basic suggestions, like updating to the latest version, disabling all unnecessary devices, disabling Exclusive Mode, Enhancements, and Hardware Acceleration, and trying different frequency settings for your devices, among others.

  • The Bass Boost Effect works at 62,5 Hz (which I discovered by opening a Preset .fac file in WordPad).
  • We are aware of the current limitations to FxSound’s Equalizer. Adding more bands is a popular suggestion, see the feature request below, but it would require significant work on the DSP code.

That’s a reasonable request. Duly noted.

Hello, thanks. As with ever, after posting and a browse I discovered other instances of some of approximately the same question. argh. When having this edit window open, I can’t see the existing thread:) Ok, I’ll check the points in 1. (not beyond level 5? is that not…limiting? I understand 10/10 is generally not great practice, but 8/10 is a reasonable level?)

Do you have links to the sibilance advice suggestions? I have to say 60Hz is still “relatively” high for a sub? that’s still in the ‘hear’ it range rather than the ‘feel it’ range? (yes, I’ve got a [moderately] thumping sub with a port hooked up)

1 Like

No problem.

You’re free to choose whatever levels you want for the Effects, and it might be useful to max them out in some rare cases, but my personal experience has been that any setting beyond 5 usually deteriorates the audio quality instead of improving it.

I’ll look for some.

Yes, true. I hear you, and I understand your request.

EqualizerApo is the most precise free EQ tool out there, with infinite bands and unlimited customization options, and should be compatible with FxSound on a capable system.

1 Like

Could you share the brands and models of the devices you’re using for listening?
[EDIT] Knowing what kind of audio you’re listening to when the hiss/sibilance occurs, would also be helpful.

I was probably wrong about the tutorials.
A first quick search returned a lot of results, but most tutorials I found turned out to be aimed at voice artists, and propose using a “de-esser” as a solution in the recording process, which is likely and understandably irrelevant here.

They all agree on the fact that sibilance appears due to an excess in the higher frequencies, and I’m guessing the Dynamic Boost and Surround Sound Effects simply pile up on that excess and worsen it further.

When I put on a recording of a person talking, and push the Clarity, Surround Sound and Dynamic Boost Effects to their limits, I clearly hear a hiss getting created in the background of most recordings, like a sort of tinnitus. But this sounds to me like the simple background noise which is found in most live recordings, just getting highly amplified due to the Effects boost.

Can you notice a similar difference, between live recordings (e.g. standup comedy) and studio recordings?

Hi I’ll go through the other points when I have a chance to check them in detail. :slight_smile:

I’ve actually got this installed as well. I don’t know if I’m missing a setting, but I’ve tried using the peace equalizer to boost just the 21 and 42Hz bands, and actually all that happens is that all of the mids and trebles get massively suppressed - it was like listening to something underwater or something as a random example

1 Like

If you have a subwoofer, it probably needs to be EQ’d separately. So I’m guessing that’s the cause of the underwater effect.
That’s just a guess, though.

I actually un installed peace equalizer because if it can’t take care of the sub, it isn’t really any use. but frequency bands are just frequency bands? shouldn’t really matter where the EQ is coming from, the EQ should just boost that particular frequency band and the circuitry inside the speakers should “distribute” it accordingly?

1 Like

Another quick query. Whether you can confirm this or not. Using Fxsound with the clarity and dynamic boost enhanced, when the trebles are up, there is the background hiss. Now when I use the VLC EQ to adjust those same frequencies, there isn’t the background hiss. So,

FX clarity/dynamic boosted, Fx EQ treble boosted - hiss
FX clarity/dynamic boosted, Fx EQ at flat, but VLC treble boosted - no hiss

Can you reproduce this?

1 Like

I’ve tested, I get the “hiss” both with FxSound and VLC.
I set VLC’s EQ to “2 Pass.”

Do you have a link to the audio you tested with?

Hi, actually the audio was silent - the hiss seems to be amplified “nothing”

I’ve just re checked with all source sound silent, and maxing VLC’s treble EQ (2 pass or single, everything above 1kHz) is silent, while maxing the FXsounds treble (everything above 1kHz) gives the hiss

I can re check my recheck sometime! it does sometimes get difficult to remember what options I have or haven’t selected. but afaik, the test ‘settings’ are identical

1 Like

for what it’s worth, I’ve discovered another third party EQ - called PC Equalizer free. this actually has a nice spread of frequencies. (useful for youtube music (because VLC’s EQ doesn’t work in youtube), PC Eq free goes to 31hz)

PCEf also gives the hiss (with silent source audio). PCEf doesn’t have clarity and boost settings though, so I’m filling up the screen with EQ boxes :stuck_out_tongue:

(that’s actually in fact another question…could the interface be compacted?)

I believe your results.

Currently using Bose QC45’s; even with Clarity, Dynamic Boost, and the three high-frequency EQ sliders set to 10, I still get pure and simple silence on an empty audio track.

Have you tested with multiple devices? It might be device-specific.

You can switch to a miniature version of the UI by clicking the button with the two arrows pointing towards each other in the top right corner.

hmmmm. I’ve tested it on 3 sets of speakers so far, hiss happens on all 3 (edifier R1280DB’s (my nice music speakers) Ultimea s50 (soundbar+sub for films), and a cheap fifteen quid soundbar from ebay which happens to be good for speech)

there are some other parts of the hardware audio setup I could check (3.5mm jack plug switches etc). when I have some time for unplugging things :slight_smile:

thanks, only problem with the compact view is it doesn’t have the sliders - there seems to be a lot of sort of “blank estate space” with the full view

1 Like

It could also be a machine-specific issue, caused by the inner workings of your computer… I don’t know.

yup I thought of something weird like that…some ground loop or something strange. sigh. I’ve just done a hiss test, and unplugged the jack from the laptop - hiss disappears. so whether it’s something to do with the laptop or not… I actually have another laptop I can test with. sometime - when I can do the testing…later sometime :stuck_out_tongue: I’m still at a loss as to why VLC’s EQ doesn’t do it thought. maybe a driver issue

1 Like

While I’m here another minor request which other people may or may not agree with. When you change EQ settings the question is do you want to ignore current changes yes/no. would it be easier for the question to be do you want to save current changes yes/no? so the button to click would be yes to save or no to continue (ignore), rather than yes to continue (ignore) and no to save. just a preference idea

1 Like

Good idea. Shouldn’t be too hard to implement, either. I’ll pass it on.

1 Like