Echo due to Fx AND the original playback device playing at the same time

I noticed echo after downloading another program that turns my phone into speakers for my PC and that seemed like it conflicted with Fx as I heard both my phone and Fx play the same audio on my PC.

When I realized this, I deleted the program but could still hear echo. I checked the sound settings and found out that Fx and my headphones are playing the same audio on my PC at the same time. Tried using another headphones, reinstalling Fx, troubleshooting( maybe not correctly), and even updating my headphone’s drivers all to no avail. HELPP MEH

1 Like

Good afternoon,
If you want to get rid of FxSound, try uninstalling the driver manually (since the risks involved in uninstalling the FxSound driver are close to zero).
Please note, you will need to restart your computer afterwards; and you’ll probably still want to check your Control Panel (under “Uninstall or change a program”) to verify if FxSound is uninstalled there, and if not, uninstall it through Control Panel as well.
First, these are the instructions on how to check if the FxSound driver was installed properly:

And these are the instructions on how to manually delete the driver:

Which one was that, and have you tried visiting their support page, subreddit, helpdesk and/or forum?
Because it sounds to me like FxSound did not create this problem, and was working perfectly fine before you installed that other program.

This is a quick copy-paste of my standard list of settings I usually recommend checking first:

  • Make sure your computer, Windows and sound drivers have received all the latest updates;
  • Try completely removing and then re-adding the problematic sound device(s);
  • Try browsing their manufacturer’s website to find and download software built specifically for your devices;
  • In the General section of FxSound’s Settings menu, try changing the setting for automatic switching;
  • Try running FxSound as Administrator;
  • In the Windows Sound Settings menu, make sure all your devices match at the same setting, with “24 bit 48000 Hz” being the maximum supported by FxSound;
  • In Windows Sound Settings, make sure the FxSound device is set as the Default Device;
  • If this doesn’t improve anything, try setting FxSound as the Default Communications Device;
  • In Windows Sound Settings, disable all Enhancements including Loudness Equalization for all devices;
  • In Windows Sound Settings, disable Exclusive Mode for all devices;
  • In Windows Sound Settings, disable Hardware Acceleration for all devices supporting this option (can usually be found in the Advanced tab);
  • In Windows Sound Settings, disable all the devices you don’t need, including the hidden ones;
  • Try downloading the program from a different source and installing that version instead (if you’ve downloaded from, try downloading from the Microsoft Store and vice versa);
  • Try uninstalling with specialized full uninstaller software (not an obligation and more of a last-resort option).

Heyyy, OK SO-

1 - I uninstalled Fx Audio Enhancer and AudioRelay (The application I was talking about) from the device manager because deleting them from the control panel is not enough. So now my PC is completely free of any other audio app.

2 - They don’t have a subreddit but I tried searching their FAQ to no avail.

3 - I tried almost every single point in your list but that also did nothing

4 - Should’ve provided this from the start but this is what it looks like when I said that both Fx and the original sound device play at the same time:
Also about:

I think so too, it was working completely fine up to that point so I’m probably the cause of the issue. AHHH I’m so sorry but am just out of options, I rly love Fx it really came in clutch and this forum page’s UI is so perfect.

1 Like

But there are still two devices playing simultaneously?
Have you tried removing and then re-adding the problematic device?
Here’s something you could do really quickly: disable, and then re-enable the device(s) involved.


@Aiwaku is experiencing an echo effect caused by two devices playing simultaneously after installing AudioRelay in combination with FxSound, and I tagged you to ask you if you have any advice or suggestions regarding a possible fix.
Thanks, guys.

Sorry for the late reply, yes I tried disabling either so here is what I found. I’ll call (original playback device) High Definition Audio Device: HDAD

  • Sound cuts if HDAD is disabled even though Fx shows that it’s still playing.
  • When Fx is turned on, HDAD gets modified yet Fx also keeps playing the original HDAD audio
  • When Fx is disabled, it obv just stops working and HDAD audio is playing alone
  • Same thing with volume, if I decrease or increase audio in Fx through properties, HDAD complements the volume change and vise versa
1 Like
  • Have you tried setting the High Definition Audio Device as the Default Device and FxSound as the Default Communications Device?

  • Have you tried completely removing and then re-adding the High Definition Audio Device?

For the above-mentioned reasons, please consider also asking for help here:

Also, there are alternatives to FxSound out there…
Some examples:


I have tried both

Tysm for your help, I kinda gave up cuz this is taking a lot of time so I started using EQ extension for Chrome and its working just fine. Maybe something’s wrong with my PC, I haven’t factory reset in 6 years lol.

1 Like

Sorry to hear that.
I truly wish there was more I could do.

If you want my opinion, I’d say EqualizerApo is a much better, much more advanced tool - but, of course, it’s completely up to you to decide what you want to use.

1 Like