Discord screen share echo


I’ve been using Fxsound while screensharing on discord and my friend can always hear an echo of the video’s audio so they’re hearing the audio twice, been very annoying and i’ve tried things like turning on echo cancellation on discord, noise suppression, changing mic sensitivity, im using the right output devices, and when I look in the sound settings there’s always two speakers, the original laptop speakers, as well as the fx sound speakers that are playing so i think this is the reason why it’s echoing but I can’t disable either of them.

Thank you!

1 Like

Hello Rice, welcome to the forum.
The fact that there are two devices active in your Windows Sound Settings is normal when using FxSound, since it has been described as working like a virtual sound card through which the audio stream is processed, and is not your actual output device.
The fact that you can’t disable any device seems strange, though. The easiest way to stop FxSound from processing your audio while on Discord in this case, would be to simply turn FxSound Off with the main Power button. In the latest update, there’s also a Default Preset with a zero processing value present in the drop-down Preset selection menu, and you can also exit FxSound using the Exit option in the menu opened by right-clicking the tray icon.
About the echoes: the Clarity, Ambience, Surround Sound and Dynamic Boost sliders are the most likely suspects for those.
The Surround Sound effect widens the stereo spread, and the Ambience effect purposefully adds a form of echo known as reverb a.k.a. reverberation to your audio output, while the Dynamic Boost effect boosts the general volume.
Try keeping these sliders below 5, and the Ambience slider in particular below 3, or down to 0, and see if there’s a difference.
Another contributing factor in this scenario could be the fact that you’re using your laptop’s own built-in speakers. Have you tried using any other sound devices yet to see if you get the same results?

Issue is 100% caused by FxSound, ever since removing it, I have no issues. Perhaps look for another audio enhancing app and test with it. The reason it happens is that it recognises both your own audio and the audio enhance from FxSound, since Discord picks both of them up, they share both audios. Also disabling FxSound through the power off button in the app didn’t work, it had to be a disabling of the audio device through Control Panel.

If there was a way to ignore picking up of the sound from Discord or perhaps, FxSound not acting as a second Audio device, would work I imagine. I also tried with Speakers, Headphones - On/Off, different presets. Nothing worked until I disabled it and it’s all okay now.

1 Like

Installed SteelSeriesGG, issue fixed and since I was using FxSound for audio boost, it has even more tweaks and works just lovely, no double audio when sharing screen either.

1 Like