Bug Report: Switching Devices Disables Sounds on Discord

Hi again, sorry for troubling you so much :slight_smile:
As I mentioned in the topic, I need to reapply FxSound as current output device in Discords sound settings. Sometimes that works for 5 seconds and the sounds go away again. I need to restart FxSound and Discord. After restarting I need to select my current connected device both from FxSound and Discord
Much appreciate your valuable time, keep it up

1 Like

Have you tried these yet:

  • Point 9 of my standard troubleshooting list - try setting FxSound as the Default Communications Device; this actually sets FxSound as both the Default Device Γ nd the Default Communications Device simultaneously, but only shows it as the Default Device:
  • Point 13 - in Windows Sound Settings, try setting your Communications option to Do nothing:


Points 10, 11 & 12:

  • In Windows Sound Settings, disable all Enhancements including Loudness Equalization for all devices;

  • In Windows Sound Settings, disable Exclusive Mode for all devices;

  • In Windows Sound Settings, disable Hardware Acceleration for all devices supporting this option (this option can usually be found in the Advanced tab);

Inside the Settings menu of your Discord app:

  • Go to Voice & Video and select FxSound as the Output Device;

  • Go to Voice & Video and disable Hardware Acceleration;

  • Go to Advanced and disable Hardware Acceleration there as well;

  • Go to Voice & Video and select Standard as Audio Subsystem:

Please post back after having tried these tips, and let me know if they were helpful or not.