Audio delay after installing FxSound

Hi all!

I’m using Roland Rubix22 audio interface paired with AKG K712 pro headphones and after installing FxSound I have a lot of audio delay when playing videogames like Counter Strike (CSGO).

I used Equalizer APO+Peace before with no problems at all. I make sure APO and Peace are uninstalled now so they don’t interfere with FxSound.

What can be causing this audio delay?

Thanks in advance!

1 Like

Hi Sloty,
Yes, this is a known issue.
First of all, you should make sure you have the latest version of FxSound installed.
Secondly, here’s some good advice by one of our users:

Taken from this thread:

Hi! so I tried this LatencyMon software and these are the results:

With FxSound ON:

latency_report_with_fxsound.txt (9.9 KB)

With FxSound Closed:

latency_report_without_fxsound.txt (9.5 KB)

I attach the txt reports too just in case

Can you help me out? I’d like to test this software but I’m running on some real problems here

Thanks in advance!

1 Like

Here’s one tip Vijay gave:

And of course, you can disable CPU throttling settings in your Control Panel, as LatencyMon suggests.
What exactly do you need help with?
Which software would you like to test?
I can’t read your mind from a distance you know, you need to be specific.
Here’s what @PLEASE_DELETE said:

Look, let’s not kid around.
This is a known issue that’s been reported multiple times, and there’s probably not all too much that can be done about it and not much of a solution for it, except perhaps replacing your entire operating system with a more powerful one.

The software I’m trying to test is FxSound mate xD.

So I tried unplugging my audio interface and plug it again and now LatencyMon is showing normal values even with FxSound ON:

But the audio delay is still happening on CSGO. Maybe not as much as later on.
My operating system is Windows 10 and is up to date, which OS do you recommend?

Thanks in advance :slight_smile:

I meant your computer, the hardware, the machine.
The delay during games is a known issue and as I said, there’s not much that can be done about it.

How so? I’m using a Xeon x5675 4GHZ with 24GB RAM :-\

First time this happens to me testing a new software and you tell me I have to update my hardware? jaja. Ok mate

Okay, did not know that.
Guess it’s not your hardware causing the issue then.

Always helpful to include information like that in your opening post…