Stop override default output device

Pls stop letting the app override the default output or at least pls let me disable it. I use Voicemeeter and Eartrumpet to route the audio but when i install the fxsound, i lose the ability to route what audio will go through fxsound and what not

1 Like

I agree - it can be very annoying when it just takes over a device you don’t want it to at times, or vice versa… Sometimes I have to reset default device in windows config, and/or restart my audio application to get it to work again as well…

Edit I should note this only happens if I am changing devices, like plugging in my Turntable or unplugging my Aventree leaf, or plugging in a Native Instruments DJ controller etc etc… Maybe this is normal? IDK… (Yes I use a lot of different devices with a M-Track 2x2m).

Okay thanks for the feedback. Maybe we’ll add an option to disable this. We keep it enabled so that FxSound will continue to process audio when users swap output devices in Windows, but I could see how this could be annoying/confusing in some cases.


Any idea when the Downloads will work again? also since you are hosting them on an “insecure” site, IMO, can you provide MD5 hashes of the correct downloads moving forward, as I don’t want ANY kind of malware of infected stuff by any chance on my PC, thanks!

Also the latest version well not the latest cuz I cannot download it lol but the version prior works a bit better on switching outputs. thank you for whatever you did there… :slight_smile: