Shortcuts setting overrides keys

When I tried to @ someone on Discord, it didnt work. Instead it notified me that Fx Sound is now off. I looked in the Fx Sound settings and noticed that there is a shortcut which used Alt and Q. On german layout [QWERTY] that is the combination for “@”. When I deinstalled Fx Sound my @ worked again. Please fix because I love your software but I want to use @

1 Like

Hi CoolGermanGuy,
While I understand this is annoying for you, I would personally opine it is too much to ask.
The world is an incredibly complicated place, filled with a plethora of smaller incredibly complicated things; so some paradoxes, contradictions and errors are inevitably bound to occur.
The makers of FxSound put a lot of thought and effort into their creation; to ask them to go and change the very code of their program in order to fix one single, tiny, and very specific incompatibility, seems quite silly to me.
Nevertheless, since this is, of course, only my own opinion, I will hereby pass your request on to FxSound’s owner @james for his personal consideration.

Nono, I dont want them to change the code. It’s just that the option “Disable Shortcuts” is automatically turned on and I cant turn it off plus its not working properly

1 Like

Yeah, okay. Good point.
This is a known and multifaceted issue, which needs further staff attention.

my point here is that I cant use the @, which is essential for communication in my case

also as said before, I love your software and dont want to be mean

1 Like

I never said you were being mean. Sorry if it came across that way. That was not my intention. I do understand your predicament.
But there are so very many programs that exist out there; and to assure complete compatibility with each and every single one of them, would be sheer “virtual insanity,” and would render the development of any project quasi impossible.


Besides, there are other ways to ping people on Discord:

Okay, did some searching; decided to make another post, since it was not my intention to fob off your concerns as entirely irrelevant.
So to further address your issue…
This was posted recently in the “Discontinuing Active Development”-thread:

And this was @james’ reaction:

The good news for you here is that, since new certificates are currently in the process of being purchased, and development has been (modestly) restarted, this issue should probably be dealt with in the near future.

:face_with_raised_eyebrow: …I’m sorry, please forgive me if I’m rambling, getting confused, or just being downright stupid, but - to be clear:

  • You say the keyboard shortcuts are disabled
  • Yet when you press the keys corresponding to one of FxSound’s shortcuts, it actually does work?

I’m simply asking because it would seem to me that, logically speaking…
If having the “Disable Keyboard Shortcuts” box checked, doesn’t disable the keyboard shortcuts…
Then un-checking the “Disable Keyboard Shortcuts” box, probably won’t get you very far either…
…But perhaps this was exactly the problem user @Milincho was reporting in the first place?
In any case, there appears to be some seriously mind-blowing Orwellian DoubleThink going on here – either that, or I’m just a complete and utter idiot.

…Deafening silence… :zipper_mouth_face:

Every solution has a problem. Please identify your operating system.

Two problems are reported in this thread. One is internal to DFX (won’t save state). Because my install does not have this problem, I will not examine.

But this is true - the solution exists and works as designed in at least one installation of the software.

You are describing a hotkey conflict. If we accept that DFX cannot resolve the write error on the saved state, there is no option but to re-assign the key thru a third-party app or setting. Google '[hotkey manager]

Meiner Meinung nach ist der Aufwand gerechtfertigt. Die Software ist unübertroffen…

1 Like

My os is Windows 11 Home or Premium, thanks for responding

1 Like

Top-notch input as usual, @Antman (and something I didn’t even know existed, by the way).

Write my headstone in EBCDIC.

1 Like



Popular like trump

Does the job like Joe

Your install should save the setting. My “tip” is a hack. I would use SharpKeys to create the registry string or entry. Then, I would save that as a .reg file for future use. On a new OS install, if the setting continues to fail, merge the reg file. No need to install a keymapper.

Pro Tip:
Modify that file to remove the settings. Save both ie “KeymapEnable.reg” and “KeymapDisable.reg”

There is nothing proprietary about key mapping.

1 Like