Keeps changing sound device

I use Voicemeeter Potato to manage and control which app goes into my speakers. I like using FxSound for my music and I usually connect my Airpods to listen to that music. The problem is when I do connect my Airpods, the sound device ALWAYS switches to “FxSound Speakers (FxSound Audio Enhancer)”. I still hear the sound and the eq doing its job, but I cannot change my volume level unless I manually change back to my Airpods output device.

I have already tried enabling and disabling “Automatically switch to newly connected output device” but it is always the same result. It gets extremely annoying having to do this since it is bothersome and takes time. Is there a way of getting this software to properly cooperate with Voicemeeter’s control over output devices?

1 Like

Hi,
Have you seen this thread? It might be helpful.

Yeah, this is just one of FxSound’s kinks.
That’s just how it rolls.
I don’t think there’s much you can do about that, except disconnect Potato from your setup entirely.
Sorry.
@TiM: Am I wrong? If so, please correct me.

Well, we have a setting that says “Switch to latest attached audio device” which can be disabled.

However, i do not know “Voicemeter Banana”, if that does not work.

1 Like

User has already tried that.

Ah I understand. Because it is a problem with a lot of people, if not everyone who uses Voicemeeter, will the issue be fixed or worked around? For example, including an option that enables or disables the app from automatically choosing its own output device as the computer’s output device.

If it is suggestable, it would be a great addition to sit alongside the option to automatically switch to the newly connected output device.

1 Like

As far as I know, it is necessary for FxSound to perform said behaviour in order to work.
So I doubt this will be changed in the future.
There are an awful lot of machines and programs out there, and I fear this is just one of those unfortunate incompatibilities.