Can't Install FxSound? (Installation Troubleshooting)

If you’re having troubles installing FxSound, the first thing we’d recommend is making sure to uninstall any older versions of FxSound and/or DFX. Then try downloading and installing the latest version. Download the latest version here.

The second thing we’d recommend is to be patient once the installer is running! Depending on your computer, FxSound may take a few minutes to install and it could look like the installation process has frozen. (We’ll be working on adding a better progress bar in the future).

It’s also possible that the FxSound driver was partially installed but disabled during the installation process.

To check to see if this has happened on your PC, search “Manage sound devices” in Windows and open that window.

You should see a section titled “Disabled”. Check to see if “FxSound Speakers” is an option in the Disabled section. If it is, click the FxSound Speakers card and Enable it.

If you’re still having troubles please leave a comment here and the FxSound team and the community will do our best to help you asap!

1 Like

FXSound is not listed as an output (or input) device in my Sound Settings. I am running Windows 10. Here is a screenshot:

Hmm… did the FxSound installation complete or no?

Thanks for being here! It’s really nice to have someplace to go for help and I appreciate that you do this.

Every time I’ve tried installing FXSound I get a “Settings file not found!” message. This happened when I tried it last year and I gave up. Now it’s free (yay!) and I’d like to try again.

Downloaded DFX gold and it installed and it worked (as much as it can with no serial number). I just used Revo to uninstall all traces of both programs (I had been using DFX, first time in 2006, but didn’t reinstall with my last computer), downloaded again and I’m still getting the same message. It does show in my devices.

Win 10 system, Realtek audio

FXSpeakers are showing as an output device. There is sound when I choose “Speakers/headphones (Realtek Audio)” as the playback device but no sound with FXSpeakers.

Thank you again.

I just downloaded FXSound onto my laptap and it works like a dream. I rebooted my PC, still get that same message.

1 Like

After a fresh installation, I uninstalled it with Ashampoo UnInstaller 9, reinstalled and crashed, and then the installation kept crashing, and the installation failed. How to solve it?

Hi, I also use Ashampoo Uninstaller 9. I did notice however that when installing FX-Sound (and previous FX-Sound versions) with Uninstaller 9 running, the FX-Sound Installation would fail and cause the explorer to crash as well. There’s conflict between these two programs it seems. But what worked for me was terminating Uninstaller 9 before installing FX-Sound. After successfully installing FX-Sound, you may run Uninstaller 9 again. Let me know if this worked out for you.

1 Like

I’ve installed FxSound and all was fine, but after turning PC off and back on I’ve got notification about troubles.

In my WIN10 there is no Sound Settings section, but in Device Manager device marked as having troubles. It’s properties looks like this:

What should I check next?

UPD: After 2 reinstalls it works again, but it’s not the first case…
Previously it was fixed by itself just by running update.

I never get an option for FxSound in my device list when trying to install. It did add an “Unknown Device” under Sound, video and game controllers, but when I click on that and hit update driver, then select my C drive, it eventually comes back with this…

Okay, it’s been two weeks since I posted that I’m unable to install FXSound.

DFX DOES install and DOES work. Is there anyway to pay to get a license for it so i have all of the options? I understand FXSound is free, but that’s no good to me if I can’t get it to install properly.

It’s really frustrating.

Does anyone at FXSound even look at these forums?

Turns out it was a permissions problem for the file Program data>FXsound

A google search took me to where I found the fix.

I took ownership, now it installs.

Just in case this helps anyone else who has the same problem.


Update: I noticed that not only FxSound, but none of my drivers were being allowed to be installed or updated. An admin CMD run of SFC /Scannow fixed it.

1 Like

fxsound vr 1.1 .15 Beware KIS(kaspersky internet security )block the communication of the software)its dont make rules one the first time after the install (close your firewall disable kis security at the insall ,problem it make its turning in round
oldess vr 1.1, 13 and 14 same problem p.s dfx sound was asking to comfirm the rules
sory fore my english im french guy