Always-on-Top Problem

Hi everybody.

First of all, I want to thank the devs for making this gem available for free.

Now, to the problem:

When calling the FX Sound interface, either from the system tray or the taskbar area, the program responds but doesn’t go on top of the other active windows. It always goes behind the other windows. That was not the case in previous versions. This started with version 1.1.22. I’ve tested it on working and freshly installed AMD and Intel systems with absolutely no difference. Exactly the same behavior.

I guess it’s a bug, so I’m just letting you guys know.

1 Like

Maybe other programs working with attribute “always-on-top”, see this - https://www.howtogeek.com/196958/ways-to-make-a-window-always-on-top-on-windows/

Windows 11?

1 Like

On my W11 Pro 23H2 it always starts on top, but doesn’t stay there, of course, when you make other windows from other apps active, they will then go on top, as usual.

Suggested work-around if you really want FS to stay on top:
Use the PowerToys to get it done.

Download and Install PowerToys, if you’ve not already done so. Lots of nice tools in there.

When in need of a window to be always on top e.g. for FS:
Open the FS interface, then press hotkey Ctl -Win-T for the Always on Top functionality.
Works like a charm!

2 Likes

It’s 10 22H2.

1 Like

Thank you for the suggestion. I’ll try Power Toys. But again, this is not normal behavior because this thing with windows should be dynamic. The latest active windows should always be on top by default (which is the case with my settings). Thanks again.

1 Like

ok,

Which program windows are always on top?

2 Likes

Whatever is active. It even goes behind Windows Explorer.

1 Like

But you can choose fxsound window, and he’s gone to top?

1 Like

@bvijay:

Hi Vijay,
I was wondering if you are able to replicate this issue with the latest version?

1 Like

I can confirm this behaviour for him with the new version and I also found it quite irritating.

Microsoft Windows [Version 10.0.19045.4291)

Steps:

  1. Exit FxSound

  2. Open FxSound
    Result: Good.

  3. Exit FxSound

  4. Open FxSound

  5. Open Edge Browser with Two Tabs in Split Screen

  6. Click on the Left Browser Window

  7. Click on the Right Browser Window

  8. Click on FxSound (appears behind both Edge Windows)

Hacks:

If I right click on fxsound icon → Open (it will open on top of other windows) and it will work as intended until I click on Edge Windows again OR I ext FxSound and open it again.

You can see the TASKBAR icon show that it’s being toggled (appears/disappears) but no FxSound window appears on top of other windows.

The ONLY things that changed with this SYSTEM is Edge Updates and Windows Updates. I have also just updated FXSound – the previous version worked with the same Edge Update.

I noticed that the FxSound Icon has been updated to indicate that it is processing sound rather than the previous so the bug occurs in that region of code with regards to focus.

2 Likes

If the FxSound icon in the taskbar is clicked then the window comes on top.
After closing the window to system tray, if the system tray icon is clicked, I see that the icon is displayed in the taskbar but the window does not come on top. After clicking taskbar icon, the window comes on top.

I will look into the fix for this issue.

3 Likes

Tnx man, much obliged

1 Like